Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
I recently bought a 1987 samurai with the stock 1.3l engine and from why the previous owner told me the carburetor was changed but he said it was an off brand from eBay and didn't know what kind it was. I can post pics soon. I noticed a lot of vacuum lines are missing and that concerns me because the engine idles really rough at start up and smokes which leads me to believe the engine is running rich. The exhaust smells like gas and it leaks into the cabin which bothers me for not only the smell but the safety issue of breathing tht in for long periods of time.

Now before I go tinkering with idle adjustment screws I'd like to fix the vacuum lines and see if 1 that helps with the richness of the mixture and 2 the rough idle at start up.

I've read and tried to decipher the picture of the vacuum diagram under the hood and I've read acks FAQ 2-4 times but I just don't understand it and it seems like everything in the diagrams and pictures is from a completely different engine. Nothing is in the same place and I'm not farmiliar with the different sensors.

Please can someone dumb this down for me or help me find where I can find the answer.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #3
Come on guys I know someone here has the ability to look and compare engines to help me figure out what lines go where.
 

·
Registered
Joined
·
264 Posts
If it no longer has the stock carb and emisson control system componets in place, there is really no way to figure out what is supposed to go where. I can tell from your pictures that one missing item is the stock air cleaner, which had an air temperature intake control. You are also missing a vacuum line to the EGR valve. Here is a good guide for figuring out what a stock system should look like and trouble shooting.

http://zukioffroad.com/Tech_Library/pdf_documents/1986-1988_SuzukiSamurai_emissions_manual.pdf
 

·
Registered
Joined
·
47 Posts
Discussion Starter #5
If I find out what carb I have will that help or is it still just a crap shoot at this point. From reading that link that was really helpful by the way I suspect the egr valve is missing a vacuum line causing my rough idle at start up and the fuel smell in the exhaust. If finding out which carb it is will help how can I tell which one it is? I'm fairly certain its not a weber carb but ill have to try taking it off for inspection of the internals.
 
1 - 5 of 5 Posts
Top