Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 1996 Alto Spark (GL). For weeks now it's driven great, but a few days ago it developed a loud clicking/popping sound from one of the rear brakes.

It doesn’t make noise while turning so I'm sure it isn’t worn wheel bearings, it also doesn’t occur when I'm just driving, so I'm sure it's not a rock or nail in the tire.

Problem is that sometimes it makes the noise and sometimes it doesn’t. I'm wondering if a pad is loose, but I don’t feel anything odd through the pedal, it still holds tight and there is no vibrations.

Any ideas on what it could be?

Thanx.
 

·
Registered
Joined
·
8 Posts
well enola!.......

Are you sure its coming from the rear brakes or can it be from the rear door?







Originally posted by enola@Aug 4 2004, 02:09 PM
I have a 1996 Alto Spark (GL). For weeks now it's driven great, but a few days ago it developed a loud clicking/popping sound from one of the rear brakes.

It doesn’t make noise while turning so I'm sure it isn’t worn wheel bearings, it also doesn’t occur when I'm just driving, so I'm sure it's not a rock or nail in the tire.

Problem is that sometimes it makes the noise and sometimes it doesn’t. I'm wondering if a pad is loose, but I don’t feel anything odd through the pedal, it still holds tight and there is no vibrations.

Any ideas on what it could be?

Thanx.
 

·
Registered
Joined
·
1 Posts
Did you ever find out what the cause of this was? We had this problem with out Ignis, it was a stone stuck somewhere. It happened again recently, and it was also the case with an Alto that we took for a test drive. The suzuki garage said the best option was to wait for the stone to find its own way out.
 
1 - 3 of 3 Posts
Top