Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Noticed a lack of acceleration at higher speeds. Couldn't get enough speed up to overtake on motorway/freeway. Drove around town fine for a week or so, then took it to garage for another job and asked mechanic to look at that issue too. When he was test driving it after other job (5th gear synchro, now fixed) it has got worse. Now hard to start, runs really rough when it does start. Some issue with fuel getting through? Throttle body? Fuel punp? But no fault codes showing on diagnostics! Any suggestions much appreciated. Thank you
 

·
Registered
Joined
·
8,452 Posts
Dont guess!

You need to record the fuel trims at idle/2000/3000 rpm... what are the trims at full load (foot to floor on road)?

Have you checked for a restricted exhaust?

What did your mechanic suggest the issue is?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
  1. He doesn't know as neither of his diagnostics systems show any fault codes for this. He has considered throttle body then fuel pump but cannot be certain as no faults report. Someone suggested fuel blockage/dirty fuel and running it, at high revs but mechanic says it has deteriorated and will not rev like that.
  2. I had a different issue when I first got the car, with occassional loss of power, which turned out to be Crank Shaft Position sensor. Again, nothing showed up.on diagnostic tools. Suzuki main dealer mechanic was adamant that the Crank Shaft Position sensor could not be the solution, but it was. So I wanted to ask on this Forum again, for good advice which provided a solution which a mechanic could not. Thank you
 

·
Registered
Joined
·
4,548 Posts
your mechanic is too reliant on codes to do his work for him. suck, squeeze, bang, blow its all the engine does.
90% of the faults i get have no codes. Find a mechanic that can actually use his brains and not rely on a scanner to start pointing him in a direction. Do the basics first.
Check fuel pressure after priming, while idling and bleed off time when engine stopped. plugs, leads / lances, air filter element, exhaust restriction. Check all connections. If its not bringing up codes it obviously isn't misfiring (or is it????) what else stops it revving? collapsed cat (exhaust restriction) lack of fuel, lack of air.

work the problem. its a 2003, lots of codes on the early cars only appeared on major issues.
 
1 - 4 of 4 Posts
Top