Suzuki Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi I bought a 97 sidekick sport, 4wd,1.8, auto... Unfortunately the last owner cut off the cat... Currently the vehicle is low on power, sluggish, and pings....it seems like it's running lean and not enough fuel??...I just changed the plugs and seems to definitely be running lean the plugs were very white in color instead of light brown that they usually should be... I also recently changed the fuel filter also ...the CEL is on but has been since day 1 due to cat I'm figuring??....I'm considering replacing the whole exhaust front to back with new cat also and new o2 sensors.... I'm thinking that 2nd 02 sensor is reading rich due to no cat and leaning out ECU??... By replacing exhaust and cat and 02s does anyone know if this would help my lean issue ? Before I spend the$$$ to bring it back to where it should be??.... Really wanna get her goin in the right direction with power and no pinging... Any info greatly appreciated!!!
 

·
Registered
Joined
·
1,489 Posts
Bring it to a parts store to check for codes with a scanner before you spend $1.
 

·
Super Moderator
Joined
·
24,473 Posts
The check engine light is on while the car is running. You need a scanner to pull the code that the computer is trying to tell you, which may be the answer to your issue. Don't 'assume' what the code might be. Also, have you checked the compression (engine timing), ignition timing and fuel pressure?
 

·
Registered
99 Tracker, 5 door, 2L, 4x4
Joined
·
10,255 Posts
The down steam O2 sensor's only purpose is to MONITOR the CAT efficiency. Has no control over any ECU function....

... Philip
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Hi Bex .. As far as fuel pressure goes is there a port under the hood that I could hook a gauge to?? And do u have any idea what the pressure should be??.... Thanks!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Does anyone have an idea what else could be causing this lean condition??... I'm gonna try the advice from the others who have given me advice.... It just seems like it's really staving for fuel??...another thing I may add is if running around in the sidekick and stop for an hour or so and go to start it , it doesn't wanna start unless u crank it intermittently a few times?? Thanks for any info!!
 

·
Registered
99 Tracker, 5 door, 2L, 4x4
Joined
·
10,255 Posts
Philip, Could the upstream 02 sensor cause a lean fuel mixture?? Thanks?
The ECU use the data from the upstream O2 sensor to adjust the fuel trim to spec 14.7/1.
The O2 should switch actively and without any bias.... You will need a live Data Scanner to see this, or a lab scope...

... Philip
 

·
Registered
99 Tracker, 5 door, 2L, 4x4
Joined
·
10,255 Posts
Hot start issues most often relates to Cam position sensor heat sinking...

Lean running could be caused by low fuel pressure, vacuum leaks (illegal air)

My 2c, rather that pay for LDS, buy your own.... Code scans are just a shot in the dark...

... Philip
 

·
Registered
Joined
·
7 Posts
Discussion Starter #12
I tried looking for vacuum leaks by doing the carb cleaner spray over vacuum lines and top end no change in idle?...is there a port on the 1.8 to check fuel pressure I can't see one yet?.... Also is it possible that a faulty upstream o2 sensor could be affecting fuel trim to the point that it may be leaning things out??... I think I may have more than 1 issue and these aren't my specialty and thought I may need to see a specialist??.... Thanks for info Philip
 

·
Registered
99 Tracker, 5 door, 2L, 4x4
Joined
·
10,255 Posts
There is a plug on the end of the fuel rail, if you replace that with a fitting that incorporates a schrader valve, you will be able to attach a standard FP Gauge...

Connect a vacuum gauge to an unregulated intake manifold port, a good reading should be 19-21"hg, with a dead steady needle

... Philip
 
1 - 13 of 13 Posts
Top