Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
We installed a remote starter in our 2010 grand vitara 2 years ago and since then, the keyless is working intermittently. The door handle buttons works 1 time out of 10 and the same for the keyless start. Not sure about the fob lock/unlock buttons as i don't use them really often.

The red key symbol sometime appear while i drive even if the key is still in the car.

Any idea ?
 

·
Registered
Joined
·
987 Posts
If it wasn't dealer installed I would have it COMPLETELY removed, I have had a couple of these in the shop that caused problems. Anything not compatible with your ecu is trouble..
 

·
Super Moderator
Joined
·
13,716 Posts
I will never understand why people wait (and put up with the problem) for two years - I would have had that car back at whoever did the install the very next day.

You run the risk of being locked out and the car refusing to start at all.

Possible range from radio frequency interference, installer caused damage, to just plain and simple incompatibility.
 

·
Registered
Joined
·
3 Posts
I have an Autostart 2 way fm starter/alarm combo on my 2008 and have had it for 6 years and never had a problem with it. Guess I was lucky :cool:
 

·
Registered
Joined
·
1 Posts
I have an Autostart 2 way fm starter/alarm combo on my 2008 and have had it for 6 years and never had a problem with it. Guess I was lucky :cool:
Is your GV equipped with keyless entry / start and do you have the 7 way speaker system. If so what’s the manufacture of your remote start?
I can’t find anything that’s compatible with my 06 GV XSport.
 
1 - 5 of 5 Posts
Top