Suzuki Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I got my moms Aerio.. but the car is giving a screeching sound when I first start it in the morning. Probably because my mom used to drive it…..just kidding……Anyway if some one knows about it then help me out here………….
 

·
Registered
Joined
·
38 Posts
Probable just a loose belt. Pop the hood and have someone start the car while you listen to see if you can see where the screech comes from.
 

·
Registered
Joined
·
29 Posts
Hello Biggles!........

I think I know you r u from Melbourne?
I got changed my generator belt and it is working fine now. no more sound actually it was little loose and worn out.

Anyways thank for your help.





Originally posted by Biggles@Jul 31 2004, 02:58 PM
Probable just a loose belt. Pop the hood and have someone start the car while you listen to see if you can see where the screech comes from.
 

·
Registered
Joined
·
29 Posts
its nice to see ur reply.......oh thats great u r from Canada, i love this place. Earlier I used to live over there.....but now i switched over to Melbourne. Biggle was my college friend, now i don't know where he lives.....anyway tell how do you have such a great knowledge about almost all cars?......r u dealing with cars?





Originally posted by Biggles@Aug 3 2004, 04:21 PM
No I'm from the Toronto Ontario Canada area. Glad your problem is solved.
 

·
Registered
Joined
·
38 Posts
Actually at one time I owned a car lot in Toronto but that was many years ago. Me and my friend stripped down our first engine when we were in teenagers and I have done all my own work on them ever since. I am now over 50 so that gives me 30 + years experience.
 
1 - 7 of 7 Posts
Top