Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I am looking at trying to introduce a switch to turn off front hub lock while in 4WD mode and wouldn't mind some advice. Also after running in 4WD mode for a while and later in 2WD mode along the motorway, the motor develops a kind of power lost phenominan. I suspect the manifold vacumn solenoid is leaking causing pressure in manifold to fluctuate. Hence the jerky motor. Any idea to overcome it apart from a manual hub op??

Cheers;)
 

·
Registered
Joined
·
9 Posts
Basically it would be an auto/manual hub which would have the same problem with auto's they tend to stick and never disarm manuals will be and will for ever be the best set up so what if you have to get out in muddy weather leave them locked when you know your getting ready to to some wheeling.
 

·
Registered
Joined
·
14 Posts
What engine is in yours, the G13 or the M13?

The reason I ask is that the G13 has a problem where it will suddenly decelerate even though your foot is in the same position on the pedal.
From what I have read the fault is in the Camshaft Position Sensor (I understand it is part # 33220-50g02). It is on the list of things to do to my Jimny but for the same cost I can tolerate the problem for the moment.

As for the vacuum operated FWH, mine developed a leak in one of the dozen flexible hoses so I replaced them with manual hubs off an earlier model Zuk (actually a 410). The seem to be all the same spline and the bolts line up, you will just need to make a washer that is about 5 or 6mm thick to go between the FWH and the wheel hub.
 
1 - 3 of 3 Posts
Top