Suzuki Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hi so i have a year 2000 suzuki jimny g13bb with a auto gearbox



my problem is the transmission stays stuck in 3rd in wont up or down shift

at cold idle the gearbox area makes a realy high pitched noise? goes away when warm

ive done fluid change

what i discovered was when i took of the pan was a broken shift solenoid bracket it was just hanging there

so i buy a new shift solenoid and it works a few months

then it develops were the transmission control unit TCU a clicking noise tick..tick...tick

so i change that 3 times and it dosnt effect anything clicking goes away when shifter in put in 1 but still stuck in 3rd

i drop the pan and the solenoid broken again

so this time i put another solenoid in NEW and no go

it keeps making ticking noise in the tcu and stays stuck in 3rd gear

any ideas would be greatly appreciated :(

Thanks!!!
 

·
Registered
Joined
·
15 Posts
Hi, did you ever find out what the problem was? I have the same on my Jimny 2000 model.
It is stuck in 3rd gear. The module in the dash makes ticking noises in all settings apart form 1th gear. The manual shift has no influence. Reverse works normal. I changed oil and filter. There only a very few minor metal pieces in the pan. The problem happened suddenly without any particular incident. It was driving fine, after a short stop when I restarted it was stuck in 3rd and that's it.
 

·
Registered
Joined
·
4,750 Posts
T
here only a very few minor metal pieces in the pan
Huh? ANY metal in the pan is a cause for concern, that means somethings rubbing on something it shouldn't. Chances are good theres metal all thru the valve chest and that can cause some serious issues with the o-ring seals and the very close tolerances in the valves. One valve sticks or leaks past a seal and the trans will stay in one gear and do nothing.
 

·
Registered
Joined
·
15 Posts
Hm, not quite sure what the blackish dust in the pan was. One thing is for sure, the red trans oil was rather dark, even though it was changed 3 months ago. Mind you I didn't have a filter that time to change. So I only blew it out with compressed air and put it back.
I'm not a fan of automatic transmissions, not to drive and for sure not to work on.
I may be better off looking at a conversion to manual.
 

·
Registered
Joined
·
2 Posts
I have the same problem with my 2003 jimny and Im planning to change the gearbox clutches (rebuilding kit for auto trans.). Any one knows how much it cost to replace the clutches?
 

·
Registered
Joined
·
2 Posts
By replacing the rebuilding kit inside automatic transmission solved the problem. I just replaced the kit in my jimny a week ago and works fine until now. Ticking sounds is gone. Hope it will reach until 100000 km. I replace it with 95000km only.:)
 

·
Registered
Joined
·
4 Posts
Hi, where can I get a rebuild kit for an automatic transmission? I have a 1998 Jimny Wide. G13B engine chassis JB33W-105398.

Thanks
 

·
Registered
Joined
·
2 Posts
Same problem recently

I just encountered the same problem recently.

At first, we were able to solved it by cleaning the strainer but a few months later the problem recurred. Mechanic said it has something to do with torque converter, then another said, strainer, then one mentioned butterfly issues.

Right now, my jimny is at the shop and we are planning to have the kit also.

I hope this will solve the problem.
 
1 - 10 of 10 Posts
Top