Suzuki Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all, I have just recently purchased a 1990 JA11 and it seems to be having some issues revving thru any gear once the turbo starts to spool (hesistation which causes a jerking jumping motion). I have checked Vacuum lines and lines from the turbo and intercoooler and I take and they all seem to be intact. The issue is more prominent when the lights are on so I thought it could be a weak alternator possible, but the problem wasn't fixed when I switched out the alternator. I'be searched the forums and couldn't find anything that has fixed this issue. The previous owner said he had swapped the engine out and it did not do this before the swap (he also sold it to me without telling me about the issue but when I mentioned it to him he said he could never figure it out.)

Thank you in advanced.
 

·
Registered
Joined
·
12 Posts
Blown Turbo

Brotha, sounds like your turbo is shot. Not hard to replace, pull the air intake hose off that connects to the turbo intercooler...if that's full of engine oil, then the oil seal has blown. I had a significant loss of power when my turbo blew out, I could hear the turbo grinding so I can see why you thought is was an electrical/alternator issue. A Turbo unit for an F6A engine will cost you roughly $300 up to $500 depending on where you purchase it. I would buy one directly from the manufacturer have a Suzuki dealership source on for you. Try Amazon Japan, if the dealership does not come through.
 
1 - 2 of 2 Posts
Top