Suzuki Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
HEY I am installing an amp and sub in my car (07 SX4) and have everything ready to go but i need help with one thing... where can i find access to feed my power wire from the amp inside my car to the battery under the hood, and how do i access it?
 

·
Registered
Joined
·
143 Posts
well the only place thru the fireway is dead center in the car. if you go in from the engine bay, its dead center, and when you feed a wire thru it, it will fall down right by the gas pedal. i did this with the switch wire for my PIAA lights. and then tucked it up and out of the way under the plastic of the center console thingy. and zip tied up everything else to keep it from moving and all nice n neat.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
another question...

Hey thanx for the reply but i have another question, when you fed the wire through the firewall did you have to make any new holes? and also did you have to remove the cd player?
 

·
Registered
Joined
·
31 Posts
Hey thanx for the reply but i have another question, when you fed the wire through the firewall did you have to make any new holes? and also did you have to remove the cd player?
No using my spot from the other thread, that was the only hole and the rubber forms around the power wire. It is not necessary to remove the stereo to bring it through in the spot that I did. However you have to remove it to aess the remote turn on wire.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
cool thanx but i am using the remote wire that was connected to the stock sub which i blew cuz its a piece of shit, and put the amp under my driver seat instead and sauldered up a clip so i can use that same hook up:)
 

·
Registered
Joined
·
31 Posts
cool thanx but i am using the remote wire that was connected to the stock sub which i blew cuz its a piece of shit, and put the amp under my driver seat instead and sauldered up a clip so i can use that same hook up:)
When I bought mine the dealership didn't have one with the sub. I have read that it is a piece but I have yet to experience the bone jarring bass myself.

What are you putting in?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Im installing an MTX Thunder amp to hook into my sub box which has two 10" MTX Road Thunders in it, and also i am replacing the factory speakers with MTX 6" speakers.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
HEY my amp and sub are installed and sound great! I guess the grommet on mine was in the centre right behing the deck kinda, maybe the 08 is different or something. but if anyone has some info on taking off the door panels to replace the speakers, it would be greatly appreciated.
 

·
Registered
Joined
·
31 Posts
HEY my amp and sub are installed and sound great! I guess the grommet on mine was in the centre right behing the deck kinda, maybe the 08 is different or something. but if anyone has some info on taking off the door panels to replace the speakers, it would be greatly appreciated.
Two screws, one in the door handle where it opens and one in the arm rest. The screws are behind little plastic covers. There is a notch in them that shows where to open them. Plastic Retainers that pop out all around the edge of the panel. You can pop off the panel by hand or by using a tool, I would reccommend the tool. Be careful and take your time on the wiring plugs that are on the front panels as they are a little "tight" and do not slide out easily even if you have correctly depressed the release clips.. The drivers door has two plugs, the front passenger and rear doors have one.
 
1 - 10 of 10 Posts
Top