Suzuki Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,
I have a 2001 Jimny engine 1.3L 16V M13A (engine code)
I seem to have a higher and higher consumtion rate of fuel. Now its about 20L / 100Km, mostly inside city. I drive normally, not speeding like crazy.
I replaced both lambda sensors, the catalytic converter, just serviced front brakes (one wheel was stuck). Also serviced rear brakes as well.
I also checked the fuel pressure regulator, which seems to get fuel out of it. Also I noticed that not much fuel is getting out of it, only low debit. Is that normal ?
The car seems to work normal, feels even. Although, I tested a 2004 Jimny in neutral gear, and that one seemed to accelerate much faster than mine.
I thought maybe I have a faulty fuel pump. Somebody also told me to check the injectors. But I thought that the engine would shake if had any problem with the injectors.
thank you in advance
 

·
Registered
Joined
·
5,299 Posts
Where are you located? If it is an OBD2 model then you should check the fuel trims they should tell you if you have a fuel pressure problem. Have you checked that the brakes are not binding? Are there any leaks from the exhaust manifold?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I'm from Romania,
I had an error 1 year ago, the yellow check engine showed, it came out that the first lambda sensor was not working anymore. Since then I replace the other one as well.
Last week I went to the local Suzuki dealer, put the diagnosis on it, but the engineer said it doesn't have any parameter out of the regular. Should it show that fuel trims are out of value ?
Is that visible on any tester as well ? or i should go back to the dealer to ask them to monitor the fuel trims
Can I have faulty injectors which swallow big amounts of fuel ?
thank you
 

·
Registered
Joined
·
5,299 Posts
If its running very rich then that will show in the fuel trims.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Just went to a guy, to ask another opnion. He said he saw this problem in many cases of jimny and vitara. He guaranteed that once I replace the car's computer, imobiliser and key, the car would behave as normal
I'll keep you updated
 

·
Registered
Joined
·
5,299 Posts
Just went to a guy, to ask another opnion. He said he saw this problem in many cases of jimny and vitara. He guaranteed that once I replace the car's computer, imobiliser and key, the car would behave as normal
I'll keep you updated
I think that is extremely unlikely, they are a very reliable ECU.
 

·
Registered
Joined
·
5,299 Posts
Just went to a guy, to ask another opnion. He said he saw this problem in many cases of jimny and vitara. He guaranteed that once I replace the car's computer, imobiliser and key, the car would behave as normal
I'll keep you updated
I think that is extremely unlikely, they are a very reliable ECU. I think that he is not being honest.
 
1 - 8 of 8 Posts
Top