Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have an 04 Suzuki forenza and my engine light came on. i took it to auto zone and have them check the code that is reading on the engine light. The code reads P0441( EVAP Emissions System Incorrect Purge Flow). I had the gas cap changed and had the dealer change the filler neck. But the light came on again. I dont know what else to do.
 

·
Registered
Joined
·
82 Posts
Sounds more like either your charcoal canister is clogged or one of your lines is crimped or loose\leaking causing the fumes to run backwards. Maybe one of the Pro's here can give you more insight.
 

·
Registered
Joined
·
89 Posts
mine did the same thing.. when the light came on, i took it to advance to get the code. The part that gives that error is a dealer part. So I took it to my mechanic right after.. around 6 pm. He was closing up. Told me to come back first thing in the morning and he'll check it out.

I had a hunch. I disconnected battery to reset the error when I got home cause advance auto didn't do it. It never came back on.

First response from my mechanic was to check the fuel cap.

The light came on.. on the day when it was cold in the morning, and VERY hot in the afternoon.. late spring.

See, my opinion is that.. because 04 forenza is new.. it would have a lot of threshold issues in the settings that the on board computer handles. Because of the huge temperature day in one day.. caused unbalanced pressures on the valves.. and triggered an error.

Once reset, it never came back on.

Try that.
 
1 - 3 of 3 Posts
Top