Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have an 88 suzuki samurai and I am having a few problems out of my transfer case I believe. While driving it I get bad vibes through all gears and also alot of noise clacking sound. The noise intensify's greatly when I push in clutch and coast around 30mph. I jacked the entire vehicle up and ran through the gears the more strain I put on the transfer case the louder the noise the noise is in the transfercase. It does it in both 2wd 4hi and 4 low. I also disconnected the front and rear driveshafts leaving only the innermediate driveshaft the noise and vibration is still there. I pulled my tcase and took it apart everything looks pretty decent no shavings. They all spin freely. There is some slop on the clutch which engages the gears on the main shaft. Has anyone experienced a similar problem? I am going to purchase complete rebuild kit from lowrange offroad but dont know if I need to get updated front output shaft or rear main shaft or by my test I am thinking its the front input shaft but this will involve buying a new gear set which I do not want to do. Please help if you had a similar problem.

Also I have the trail tough complete wrangler kit on it. I had this kit on a previous samurai. I would get the same noise while coasting and some vibes but it was managable just not nearly as bad as this one.
 

·
Registered
Joined
·
9 Posts
I too have a mysterious noise on my t-case.

Starting the engine I put the t-case in neutral, same thing with the tranny. Engaging 1st gear no problem up til third. 4th gear there is a strange noise, like marbles clanking around the t-case. On fifth it gets worse.

Am stumped since I serviced it myself, and changed all bearings. I suspect the shimming at the back of the bearing on input shaft may be the culprit since I forgot to shim it properly.
 

·
Registered
Joined
·
18 Posts
hi check the u joints on the small drive shaft that connects the tcase to the gear box if they are stiff or loose they make clicking noise
 

·
Registered
Joined
·
47 Posts
I too have a mysterious noise on my t-case.

Starting the engine I put the t-case in neutral, same thing with the tranny. Engaging 1st gear no problem up til third. 4th gear there is a strange noise, like marbles clanking around the t-case. On fifth it gets worse.

Am stumped since I serviced it myself, and changed all bearings. I suspect the shimming at the back of the bearing on input shaft may be the culprit since I forgot to shim it properly.
Don't kno if this thread is still up, but I'm having the exact same problem ^
 
1 - 5 of 5 Posts
Top