Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
200 Posts
Discussion Starter #1
hi guys, i was just wondering why the rear washer does not work everytime i press the rear washer button. could anybody give me a checklist as to what parts should i see before concluding to buy a new assembly at a suzuki dealer? thanks in advance.
 

·
Registered
Joined
·
114 Posts
hi j-six

check if the motor beside the water reservoir is sucking water. you can do this by removing the motor beside the reservoir(be careful as the plastic clips sometimes break if forced) and putting your finger on the intake hole (the one which goes into the reservoir thru the rubber grommet) while somebody pushes the switch on. if no suction, either the pump is defective or the electrical connection is faulty. you can test the line using a tester. test the switch as well and power source. check fuses also.

if there's suction, you can jump for joy now. haha! it's just mechanical which means you need to check that the lines (tubing) are intact with all connections in place and that there is no obstruction. try blowing air through it to check. check the spray nozzle, it might have been clogged during painting (always happens! haha!). a needle or pin will come in handy here!

hope this helps.

as for my engine, yes i had it pressure tested at ATI engine specialists at their Silang shop. they didn't charge me for it anymore but gave a quote of P28,000 to rebuild my engine if i wanted! well i wasn't a bit surprised as the cars there included a BMW M3, a mitsubishi evo, and an F150 which looks like it's hiding something under the hood. they specialize in engine tuning and can make the average stock 1300cc car rival any 2liter VVT engine anyday.

hope i can see that carry manual soon!
 

·
Registered
Joined
·
200 Posts
Discussion Starter #3 (Edited)
thanks very much tibs...good idea with the engine rebuilding idea hehe, just wondering if they could rebuild a stock 1000cc f10 engine to a dohc engine :D

could you tell me what does the motor looks like? because i couldn't see any but wires directly coming out of the two holes from the windshield washer container...also, matagal na prob yan, ever since bago pa iyon na napaint-job, so deinit na rule out ang paint job problem.


yup the manual...we'll try to look for a xerox machine sa eb natin then poof! you have a carry manual in your carry :D
 
1 - 3 of 3 Posts
Top