Suzuki Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
22 Posts
Hi ppl, took my 87 sami's engine apart, put 90% back already, no sure what this rod is, also can't find my fuelpump rod, pls help, or give me the dimensions to the fuelpump rod, so I canmake another one out of music wire or old chisel.

Edit.

I changed the title of your post - so folks could have some idea of what you need help with.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
Thanks, I did find the rod, but the darn thing wont start!? it turns over fine,but wont start, getting fuel...I'm stumped! just found out the head is warped, now need to take it back apart! put it on my glass table with sand papper between it, guess I'll drag it up and down while watching TV, for few days........I guess! any better ideas?
 

·
Super Moderator
Joined
·
12,453 Posts
I'm puzzled - how can you tell the head is warped if you haven't taken it apart yet?
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
Did took it apart, then put back together, but had a brainfart, torqued with in-lb instead ft-lb! thought I had compression issues. now everything but the exhaust manifold is put back, but still not starting, then took a multi meter to the ignition coil, not getting any ground!? so jumped the ground to frame, still no go! and the coil got really hot!...so I'm sure there's a short somewhere, please help.
 

·
Registered
Joined
·
5,299 Posts
Have you got an earth from the distributor to the bulkhead?
 

·
Registered
Joined
·
264 Posts
yes sir, ran a ground from ignition coil to the firewall, thats how the I-coil got really hot!
No wonder. The ignition coil grounds intermittently through the distributor (points, on old type systems), not directly to a grounding source.
The breaking of the electrical current, traveling through the coil, is what causes the collapse of the coil magnetic field and subsequent high voltage spark to the plugs.
When you grounded the coil to the firewall, you made it into a little electric heater.
Perhaps you would be wise to look in the factory service manual, for some insight into what you're doing. If, you substituted inch pounds, for foot pounds on your head bolts, that would be only fifty inch pounds. For head bolts? That's barely past hand tight.
The FSM download is available free, from several sources.
Good luck to you.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #9
thanks, Ive got the book from autozone, but cant really make heads and tails of the diagrams! I'll post a pic of the diagram later, hopefully someone can shed some lights.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #10
Ok just found out, I had the +/- backwards, now, I've got spark, but still won't start, I'm thinking I had 1/2 tank of gas, my sami was parked sense sep 2013, also it had a keyed gas tank, but lost key, drilled it out, so maybe lot of water got in. So I'd put a whole bottle of dry gas treatment in used start fluid in the carb, only got some minor puff of black smoke coming out(didn't attach the exhaust manifold yet), but won't start! Should I put octane booster in? Or get rid of the 1/2 tank of gas left? If so, any idea how many gallons is half of tank? May not have a bucket thats big enough for it.
 

·
Registered
Joined
·
686 Posts
5-6 US Galons for half tank. Check the condition of your coil/plug wires, I have had very hard start and no start from a coil wire less than a year old.
Before you put the head back on did you have it resurfaced or checked?
 

·
Registered
Joined
·
328 Posts
So I'd put a whole bottle of dry gas treatment in used start fluid in the carb, only got some minor puff of black smoke coming out(didn't attach the exhaust manifold yet), but won't start!
My experience is that if it won't start when you are spraying starter fluid in, you have ignition issues. I've started engines that have no fuel whatsoever making it to the carb or injectors, using starter fluid. They don't run long, but they fire up for a few seconds.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #13
Wow, brain fart! Didn't realize its page2, thought no one replied, sorry for the delay, and thanks for the help.
I'd used the spark tester, getting sparks in all 4 cyls? Not enough volts?
 
1 - 13 of 13 Posts
Top