Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1 (Edited)
when i start my kizashi,
it turn off suddenly
all power gone
no light
nothing

after a while, door lamp on centre light on again but very very dim

later it shown " service start system"
and light on start button quit dim and flashing dimly
not functioning at all

what
is the problem ?

Battery die?

i am able to get a small car to perform jump start (battery to battery)
but not working
door lamp seem lighter a bit for awhile but couldn't help

is it the small car battery does not have adequate power ampere or what ?

pls help...
 

·
Registered
Joined
·
24 Posts
Discussion Starter #2 (Edited)
i coudn't get a new battery at this moment
thought jump start with a donor engine (small car) could solve the problem
but problem still same

light on start button is weak and dim, it flickering and shown "service start system"
and later it all turn off

nothing is functioning
and hear sound beeping for awhile then also turn



my battery is LUCAS 55D23LMF
i replace since august 2014
it is a dry type battery

is it the battery issue ?

anybody could give me advice ??
please
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
my kizashi start again

today i replace a yokohama 55dinL
my kizashi able to start again,
everything is normal

dash no more showing "service start system" or the triange warning symbol...

nice job.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
what is the different ?

i replace yokohama 55DinL
my old battery is Lucas 55D23LMF

what is the different between D & Din ?
Size ? since the older battery is taller.

55 is stand for what ?

L, i know is mean LEFT
 

·
Registered
Joined
·
8 Posts
Glad you solved this, when you get this error its because your car isnt getting enough power normally. Means your battery isnt putting out enough to turn it over. The oddity i've found is that the Kizashi seems damn near impossible to jump start.
 
1 - 5 of 5 Posts
Top