Suzuki Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My hot cold switch doesn't work. The whole outside liner of the control cable moves rather than just the inside. What holds the cable sheath to the heater controls. I think the problem is in the center of the pic that I took though the ash tray hole. is something missing?
 

·
Registered
Joined
·
111 Posts
What vehicle is it on?
 

·
Registered
Joined
·
14 Posts
There is a metal clip that is fastened by a phillips screw. Look for it... They don't just fall out. If it came out of that clip there is another problem with the cable binding or the valve on the firewall not moving freely.
Good luck
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
There is a metal clip that is fastened by a phillips screw. Look for it... They don't just fall out. If it came out of that clip there is another problem with the cable binding or the valve on the firewall not moving freely.
Good luck
That clip is probably missing. The cable moves freely inside the liner and I can easily move the valve outside with the cable unhooked. There's just nothing behind the dash controls to keep the liner from moving along with the wire inside.
How do I get the heater controls out to work on it? Does anybody
have a PDF servic manual on these?
 

·
Registered
Joined
·
212 Posts
If my understanding is correct.
The control cables from the back of the panel in the
cabin work with wire inside a spiral sheath.
On my '87 those wire insides have a bend at the
end where they attach to the plate where the
slides are mounted. The sheath is held in place
with a crimped clip that is part of the plate.
There is no screw holding the crimped clamp.
To see the plate:
Remove the knobs off the controls. (pull towards
yourself...slide off in your fingers)
Place all the switches and slides in the middle of
their travel throw.
Pull the plastic panel with instructions on it into
the cabin with a hooked device.
Take the fastening screw out of each end of the
slide panel.
You should be able to push the slides back into
the dash at this time. Do that.
Carefully bend the plate down into sight.
There should be 3 cables coming to the plate,
one on the left side and two on the right.
the heat one is on the right.
From that point you may be able to repair the
problem. ( add a screw or whatever)
It is not hard to replace that whole plate, just
detach all the cables and wires and find a different
one to replace it. (mine came from a Suzuki Forza
donor ... if a Sami is not available to you)
If that is not an option, you could attach a common
choke cable to the hot water valve on the firewall,
available at most auto supply places.
Hope this helps you get adjustable heat sources.
Some just open the hood and move the hotwater
switch to on and leave it there until next summer
when you open the hood and move it the other way.
Hope this helped you enjoy your Sami.
 
1 - 8 of 8 Posts
Top