Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i recently had to drive thru some very high flood water with my company's Carry. shortly afterwards i started to get a very loud and ominous grating noise if i have the A/C on and i try to drive forward.
i can change the gears as usual but when i start moving forward it's like something is broken.. and this only happens when the A/C is on.

any suggestions?
 

·
Registered
Joined
·
200 Posts
yup, it's possible. try also checking other belts which could have come in contact with it.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
ok figured it out... was hard to do by myself.... apparently the cross beam under the vehicle got bent into the compressor and the blade were hitting the beam when i engaged the gears. lol

not a particularly helpful thread i know but at least my problem was sorted out.
now al i hafta do is change the clutch plate. and the AC fan. which were also damaged in the flood.

thanks for the advice guys.
 

·
Super Moderator
Joined
·
4,453 Posts
what? There are no blades on the ac compressor. When you put it in gear? huh

RastaPasta said:
ok figured it out... was hard to do by myself.... apparently the cross beam under the vehicle got bent into the compressor and the blade were hitting the beam when i engaged the gears. lol

not a particularly helpful thread i know but at least my problem was sorted out.
now al i hafta do is change the clutch plate. and the AC fan. which were also damaged in the flood.

thanks for the advice guys.
 
1 - 5 of 5 Posts
Top