Suzuki Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My buddy has a 93 Geo Tracker 5 speed manual. It starts right up and idles fine. While in neutral and you give it throttle, it will rev up fine then go back to normal idle, no issues at all. The only problem is when you’re driving it in 2nd gear and up, when you give it throttle more than halfway, it will start to spit and sputter and sometimes stall out. Today we cleaned the EGR valve, which didn’t help. He recently replaced the fuel pump, fuel filter, and the spark plugs. None of those helped either. Air filter is clean, and the catalytic converter and muffler are chopped off. He said it was running flawlessly a few months ago, then he let it sit for a while, this is when he started having issues. Anyone else have this problem? Any insight would be greatly appreciated, thanks guys!

- Johver
 

·
Super Moderator
Joined
·
25,129 Posts
Welcome to the forum. When you cleaned the EGR valve, did you also clean the exhaust and intake ports that you would have seen when the EGR valve was off the car? You need to do that, as well. The EGR valve must snap back strongly on it’s spindle, as well as all orifices being clear.
How long did this car sit, and was fresh gas put in before it was started again, or is this running on old gas?
Is the check engine light on with the key on, and off once the engine starts?
Maybe give some more info - what is the cold idle when the engine first starts up, what does the idle do as the engine is warming up, and what is warm idle.
 
1 - 2 of 2 Posts
Top