Suzuki Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter #1
i got a 93 sierra 1.3 aus version of samuria when i change into 5th it wont hold 100kph slows down to about 90kph 4th will go to 120kph anyone with any ideas.
 

·
Registered
Joined
·
105 Posts
Discussion Starter #4
i replaced the fuel filter a couple of weeks ago and that didn't change any thing im thinking that its got something to do with the carby
 

·
Registered
Joined
·
1,230 Posts
there is a switch on the U.S. models, don't know if the AUS models have it. It's on the transmission. When you shift into 5th gear then it shuts off the EGR system. The engine doesn't put out enough power to use 5th gear with the EGR system engaged. Might be worth looking into. 5th gear is really pushing the limits of the 1.3 engine, so little things can add up enough to make it non-useable. worn Universal joints, wheel bearings, over sized tires.... any and all of these can make it labor hard, and a combination of them could put it's dork in the dirt. Make sure you get the power issue worked out, then you might look into some preformance mods for it, but don't start on the preformance mods untill you get the original issue fixed. Otherwise you're just covering up a problem that will continue to get worse and wreck other things on the vehicle.
 

·
Registered
Joined
·
105 Posts
Discussion Starter #8
thanks for the info on the egr i'll have a look when i get home in a weeks time. ive had the engine rebuilt with all race parts and had a port & polish done on it and crank shft balance i also run a 2 inch mandrel bent exhaust with extractors and a snorkel for the inbound air
 
1 - 8 of 8 Posts
Top