Suzuki Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
255 Posts
Discussion Starter · #1 ·
I have a 2001 tracker 2.0 4x4 2dr and I was heading home today after buying new rims and tires when my tracker started bucking and losing power like it was running out of gas. it sputtered and I could only do 35 mph on freeway so I pulled off next offramp. checked gas cap it was loose checked wires to maf,map fuel rail all connected. so I figured I would have to cripple home.started down on ramp and although a little sluggish got up to 70mph thought I was ok but 20 miles later I made a right turn and it started bucking again. stopped popped hood only thing I noticed is front cat was smoking(cat has 240,000 miles on it new engine has 7000) checked and wiggeled connecters again and figured I was crippling home. but just like last time I got up to speed again, no check engine lights ever came on. got 1/2 mile from home and it started bucking again once home hooked up to scanner no trouble codes.i figure cat is plugged so I figure let it cool and drive to autozone.get there and back put that 24 dollar cat/ fuel cleaner in tank and leave autozone. car was running good so I took on freeway to blow out cat. as soon as I make right turn onto freeway it starts bucking again cripple it home.still no codes use wifes car and get some MAF cleaner and clean MAF. Runs like new for 15 miles on freeway to home test drive.go home eat and fuel up directions of cleaner say do 15 more miles hey I think I am golden make right turn out of gas station and it starts bucking again,cripple home.haynes book says to turn on key and listen for fuel pump I cant hear it but tank is full and my hearing is terrible.and still no codes. if my cat was plugged wont I get a code? and if filter or fuel pump is bad should they throw a code. looking for help. do I just replace relay for fuel pump and replace filter next?
 

·
Administrator
Joined
·
19,092 Posts
Is it my imagination or does the problem always show up after a right turn?

I don't think you'll get codes for a plugged cat or a defective fuel pump or filter, and I doubt the pump relay is the problem.
 

·
Registered
Joined
·
255 Posts
Discussion Starter · #3 · (Edited)
so replace filter and check flow while disconnected into container for pressure then open up cat a little if it does not improve. at 250,000 miles I should probably just replace front cat anyway correct? also after thinking about it first time it acted up was a left turn ,I was very frustrated when I wrote this last night and got the all right turns wrong
 

·
Registered
Joined
·
255 Posts
Discussion Starter · #4 ·
update

changed fuel filter ran great 12 miles once tracker engine warm started bucking again.put an electric fuel pump between tank and filter and wired into tail light plug on trailer lights so I could turn on and see if it was tank fuel pump. since it was warm it started after a mile turned on fuel pump did not get better so ruling out fuel pump relay,fuel pump and filter since it is new and in the right direction.guess it is my cat
 

·
Registered
Joined
·
255 Posts
Discussion Starter · #6 ·
well it is at midas for front cat,save 20 bucks buying local not worth my time to install myself for 20 bucks.rock auto could have saved 80 but had to wait a week so went with midas.i don't have a low pressure gauge but thanks for the trick anyway
 

·
Registered
99 Tracker, 5 door, 2L, 4x4
Joined
·
13,273 Posts
The standard Vacuum test gauge has the ability to also test low
pressure...

.... Philip
 

·
Registered
Joined
·
255 Posts
Discussion Starter · #8 ·
found problem sort of

well got it back from shop yesterday ran like champ after one minor bump. drove 75 miles to San Diego to see a friend and it started acting up again. Let it cool headed home got 2 miles started bucking again. pulled off freeway let truck idle and started checking connectors since it was running rough. when I got to drivers side I lifted the wiring for the o2 sensors that go into cat and I believe to fuel or computer system.it smoothed out, I lowered it and it ran rough , up smooth down rough. it should be noted the bracket they are supposed to be clipped in is broken so I lifted wires with bungee cord and had no more problems. when I got home I zip tied them up till I can find short. what do these wires go to other than the cat sensors and can it be just dirty connector, jiggling wiring means a short or loose connector correct. will post pic of wires and wait for further
 

Attachments

1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top