Suzuki Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
The car cranks but doesn't turn over. It's been stalling out intermittently when we come to a stop. Until recently, it would sometimes refuse to start... but it would eventually turn over. Not so now.

The fuel pump doesn't prime. I pulled the backseat and removed the cover. I can hear the relay click when my girlfriend turns the key to ON. Just to be sure, I switched out the fuel pump relay with a good relay relay.

The fuse is intact (not blown)... BUT when I check it with a test light, there's no juice. I also tried swapping the fuel pump assembly out with no luck.

I'm getting the following codes: P0171, P0175, P0101, P0462, P0452, P0230 and P0175.

I've checked for vacuum leaks. The manifold pressure is OK. I'd like to keep the car running for another 6 months, but I'm about to give up. Next steps??

2004 Suzuki Verona
6 cylinder
 

·
Registered
Joined
·
26 Posts
OBD-II Check Engine Light Trouble Codes

P0101 Mass or Volume Air Flow Circuit Range/Performance Problem
P0171 System Too Lean (Bank #1)
P0175 System Too Rich (Bank #2)
P0230 Fuel Pump Primary Circuit Malfunction
P0452 Evaporative Emission Control System Pressure Sensor Low Input
P0462 Fuel Level Sensor Circuit Low Input

If you go to the website it will give you more ideas on how to fix.
Sorry I can not be of more help.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3

·
Registered
Joined
·
26 Posts
I looked at wiring diagram and it says B to Ground and Gr to +.
I also looked at image at rockauto of FP and it seems to confirm .
You should be able to see what wire goes to which pin.
I would be very careful as that pump is a fright for expensive.
I assume B is black and Gr is green.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Thanks. I'm hoping to have time to check the fuel pump soon. The thing that's really confusing me is why there's no power at the fuel pump fuse. I can hear the relay click when my girlfriend turns the key to the ON position. All the other fuses have power. I've also had trouble with the fuel pump fuse melting. Not sure if the issue is related.

Any idea what why I wouldn't have power at the fuel pump fuse?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
So.... I just hooked up a spark checker to 1 of the plugs... and it started.

Before it crapped out and wouldn't start at all a few weeks back, it was dying randomly and sometimes refusing to start.

It seems like some component is staying to go bad, but I can't figure it out. Based on the codes and symptoms, does anyone have any suggestions?

I'm at a complete loss and just want to keep it running another 6 months before getting something else. This car had become the bane of my existence....!
 
1 - 6 of 6 Posts
Top