Suzuki Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
..isn't working.. as the name states. cluelesss with samurai's.

so pretty much the fuel pump is working, fuel filter isn't clogged, all lines are clean, just not coming out the injector. we poured a little bit of gas in 3 times started up till the gas burned out. anyone ever cleaned one?

any help would be great.
 

·
Registered
Joined
·
8 Posts
Well i hope for your sake that its just a clogged injector or something because i know that if the ECM goes it usually shuts off the fuel delivery system.
 

·
Registered
Joined
·
89 Posts
don't know what help i can be but i have the exact same problem on my 1990 8v tracker i was trying to see if the samurai and tracker/sidekick had the same throttle body setup fuel pump and filter are new but injector doesn't work all the time i can't find a new or rebult one for under 220$!!!! i am stealing one off a buddy's to see if it works
 

·
Registered
Joined
·
2 Posts
Years ago, my son had a LTD that did the same thing. It would fire off when I poured fuel down the intake. I ended up replacing the computer and it ran great.
 

·
Registered
Joined
·
14 Posts
I would say ECM also! You may want to pull the injector out and make sure that the needle on the end moves. I have had a couple that have sat for awhile and the needle sticks. It only moves in and out a small amount so don't get crazy with it. Just put the needle up against a hard surface and push in on it, you will here a small click sound as it moves. But again ECMs are know for going out on these.
 

·
Registered
Joined
·
12 Posts
as soon as you turn the key on you should hear the fuel pump relay under dash passenger side beside horn relay- honk horn a few times to locate it.
Check the wiring - this also sends sig. to ecm for injector push.
 
1 - 7 of 7 Posts
Top