Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
Sorry to start a new thread but I cannot login to reply? Even reset P/W???

To clarify, Emergency flasher flashes running lights, not turn signal bulbs.

Turn signals work correctly until you turn on the running lights, then ALL lights flash????

The manual I downloaded from ACKS says "dimmer" switch bad when lights act funny..

Did back feeding front bumper lights do this?
 

·
Registered
Joined
·
192 Posts
IMHO
If I understand you... get rid of what ever diodes you soldered in, replace the flasher (all of $5) and just buy a trailer adapter plug that goes from the three light system to two. I think they are all of $20. Or grab two little yellow led lights and add them as turn sigs on the hitch tray.
Using the plug would be easier when you remove the tray, no? The import adaptor plugs make things easy. Remember, KISS.
Wait, didn't your trailer light kit you bought came with two yellow side markers? Why not mount them as turn sigs?
 

·
Registered
Joined
·
2 Posts
First thing. Clip a jumper lead from the trailer chassis(ground) to the vehicle chassis and re-check the lights. Its pretty common for a trailer to do what your describing because of a bad ground. The flasher cam should be fine if it is still actuating. Usually if a flasher cam fails, it will stay on or wont operate at all.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #4
Update, finally traced problem to old ground cable, driving lights wired straight to positive battery were dim also. Rebuilt battery ends of cables, and chassis ground jumper, but still no good path back to battery. Replaced what looked like good ground lead to starter mount and all is fine!
 
1 - 4 of 4 Posts
Top