Suzuki Forums banner

1 - 20 of 27 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Hello guys can anyone help me - I have a beautiful Suzuki every campervan 1997- unfortunely the engine light comes on intermittently - it loses power so I turn of the engine and start it again then it runs fine for a while again- it's had a full service - my mechanic thinks it could be the coil pack - any ideas?

Plus please help me find parts from somewhere it's a complete nightmare to find parts in the UK

I be very grateful for any advice -

I love my van - I'm a women so no ideas on mechanical stuff ??
 

·
Registered
Joined
·
36 Posts
Definitely it's something about electricity. First check the cables and spark plugs, because it's the easiest to check, if not that, then it must go on other things...
 

·
Registered
Joined
·
37 Posts
Discussion Starter #3
Thank you :) I have had a full service done - we think it could be a coil pack but what a nightmare getting parts especially in the UK
 

·
Registered
Joined
·
5,299 Posts
Which engine do you have? the coil packs should have a part number on them, you could try cross-referencing that number to see what other models they are fitted to.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #5
Found a coil pack! Yepee however not the problem :joy: any one know a cheap diagnostic machine that I can purchase for my Suzuki every van 1997?

This has been a puzzle however at least I have a new coil and air filter now

Thanks for your help I really appreciate it :) no where in my area has a plug to fit? It has 14 pins and its rectangular shape 2 rolls 7 per side
 

·
Registered
Joined
·
17 Posts
What model of every do you have exactly? Is it the 1.3 "Every Landy" (They usually have an automatic transmission) or one of the smaller "kei" versions, that'll help us figure out what engine it has. And as for the diagnostics plug, I think most of them use 16 pins, perhaps you need some sort of adapter? Not sure about that one.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #7
It is a Suzuki every 1997 660 cc

These are the plugs so far I've had a full service, replaces the coil pack - engine management is still coming on intermittently power goes then so I turn off engine and turn it back on and it's ok for a while- my mechanics where wrong with the plugs I send a picture of them now - thank you

Diagnostic plug
 

·
Registered
Joined
·
17 Posts
Ok, so that is a kei every. So it probably has the f6a engine. I could be wrong, but I don't think that's the diagnostic plug, on most cars they are generally under the dash, next to the steering wheel or by the fuse box. But I'm not sure about the every.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #11
Yes apparently that is not the plug?? I have no idea the men at Suzuki are waiting for a download fingers crossed I can put it on a dianostic on it instead of guessing thank you guys I appreciate it :)
 

·
Registered
Joined
·
37 Posts
Discussion Starter #12
Hi can you tell me which one is the diagnostic plug? The top one is in the right hand side of the steering coloum and the bottom pic is the panel next to my battery pack ( the Suzuki garage that doesn't specialise in imports believe it's one of the plugs from the bottom picture? Thank you
 

·
Registered
Joined
·
5,299 Posts
There is usually a diagnostic port under the dashboard on the driver's side, it should be a standard J1962 connector, the same connector that is used on OBD2 vehicles, however a 1997 JDM will use a Suzuki proprietary protocol they call SDL.
You should be able to pull fault codes using the monitor coupler which is a six-pin socket similar to the white on in the pic above except that it usually has a rubber cover over it.
Whereabouts are you located?
 

·
Registered
Joined
·
37 Posts
Discussion Starter #15
That helps so much thank you :) been a nightmare - I'm just hoping Suzuki can get some sort of download so they can find out what the fault is ? I am in the UK Cornwall but work in Plymouth
 

·
Registered
Joined
·
24 Posts
It is a Suzuki every 1997 660 cc

These are the plugs so far I've had a full service, replaces the coil pack - engine management is still coming on intermittently power goes then so I turn off engine and turn it back on and it's ok for a while- my mechanics where wrong with the plugs I send a picture of them now - thank you

Diagnostic plug
Very nice looking Suzuki..

By looking at the pix my first guess is that it is not a 1997 year model vehicle.

I have seen a few cases of older vehicles imported into California, USA having a newer year on the documentation (import year, assembly year, or even a guesstimate at times).

Even though you are far from California where I saw this.... it could explain your inability to find the non-existing OBD port ;)
 

·
Registered
Joined
·
1 Posts
power loss cat ?

could be that the catalyltic converter has gone bad and blocking exhaust cause poower loss happened to me on my carry till the insides completely fell to bits and power restored. fixed with new cat.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #18
To let you all know the diagnostic plug was the attachment I sent - not under the steering column- and is 100% year 1997

I'm learning more and more about this beautiful van and I'm just waiting for my map sensor to arrive then I'm selling her- so hard to get parts in the UK such a shame
 
1 - 20 of 27 Posts
Top