Suzuki Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Would anyone know how to get into Engineering mode for a 2011 Diesel Grand Vitara? And what would be the best obd2 scanning tool?

Only done 29,000 kms but has just started to flash up ESP SERVICE occasionaly.
Mainly first up in the morning, but ok after that. I took it to the Stealership and they said all was good, and charged be $60 for the priveledge. And still seems to be doing the same as before. Doesn't seem to affect the driving.

From other forum posts etc maybe the battery is starting to fail? or brake fluid level??

Thanks for any advice

Regards

Gibbsey
 

·
Registered
Joined
·
8 Posts
I'm fairly certain that when the battery is weak, and it drops below 8 volts while cranking it can affect the ECU which could result in the the error message you're getting.
(ESP Service) in orange colour.

Replacing the battery normally resolves this.
 

·
Premium Member
Joined
·
61 Posts
I had the same issue this winter. It happened only after the gv being left without starting for a couple of days in the winter at minus 20-30. Seems to be due to the battery voltage. If old battery, better off change it as a preventive maintenance.
 

·
Registered
Joined
·
5,299 Posts
You need a Suzuki or maybe a Renault tool to access engineering mode.
 

·
Registered
Joined
·
167 Posts
Agree with evodave and macrofish.

My son just had a similar issue on his 5yo diesel Xtrail (ESP off light staying on and pre-ignition after shutting the engine down).

New battery and both problems have now gone.

Cheers
Wes
 
1 - 6 of 6 Posts
Top