Suzuki Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi
my escudo model is 1991 EFI G16A 16 valve SWB.

History of the vehicle from my owner ship.
2015 owned the Suzuki. Seemed to be all running fine, but over about 6 months noticed it slowing getting decreased power out put. Long story short had a blown head gasket not sure on cause but could notice the manifold glowing red hot after driving normal.

2020
decided to try and fix it myself as I had nothing to lose, replaced the head gasket and all the other stuff water pump, drive belts etc. got it back up and going Algood turned over was happy has. But isn’t running quite right. Have set a timing light on it for 12 degrees but has no bottom end power at that, have to give It heaps of rpm and clutch to get it out of first. Also has heap of lag in the throttle. turning the dizzy to give me much more advance for TDC makes it run better. But the idle is sitting around 1500-2000 and can’t get it down on the adjustment screw. Also the manifold glows red hot after not driving for that long which I thought was weird. Any ideas ?

have had the valves redone also had the head reserved, replaced all spark plugs fuel filter, and water pump belts etc
 

·
Registered
99 Tracker, 5 door, 2L, 4x4
Joined
·
10,798 Posts
Your engine timing is off, and you are running too rich a mixture.. Keep running in this condition and you will melt the CAT..

Your attempt at adjusting the ignition timing may also damage the valves..
 

·
Super Moderator
Joined
·
25,289 Posts
Welcome to the forum. Start with a compression test which will verify the valve timing - post your results, cylinder by cylinder. Everything depends on proper valve timing which, on these cars, is done to cylinder #4 firing (many do it mistakenly to #1). Start with that, post your results, and then we go to ignition timing....lol
 
1 - 3 of 3 Posts
Top