Suzuki Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
Hey all

I recently blew the water pump and gasket , so i replaced it . I tryed to start my car but it won't idle and just stalls , i can keep it running if i put my foot down but it sounds rough and i noticed my weber carb is spitting out fuel like crazy can any 1 tell me what the go is ?? is it too much fuel or something to do with float level, its brand new weber 32/36 cheers
 

·
Registered
Joined
·
1,230 Posts
is it the 1.3 with mechanical fuel pump? or did you change to an electric fuel pump?

Are your fuel return lines hooked up to the correct tube?

Did you change anything other than the gasket and water pump? did you have the timing belt off for any reason?
 

·
Registered
Joined
·
50 Posts
Discussion Starter #3
its 1.3 mechanical fuel pump

don't have fuel return lines setup

and i had to remove timing belt to install gasket and water pump but i followed the service manual to reinstall everything

do u think its somthing to do with too much fuel goin into carby ?
 

·
Registered
Joined
·
1,230 Posts
You wouldn't be flooding unless the fuel was dumping down the throat of the carb. it sounds like the timing is off. The fuel spilling out the carb though is from your return line not being connected. Your Samurai can't burn all of the fuel that pump puts out. It needs the return line plumbed to send the excess fuel back to the tank.
 

·
Registered
Joined
·
50 Posts
Discussion Starter #7
Head gasket seems to be fine , i think its skipped a tooth i will check that out.
would u be able to spend me a pic or diagram of how the return line wants to be plumbed up and do i need a regulator?
 

·
Registered
Joined
·
117 Posts
yes, any time a weber is run it needs to be regulated to abouth 3 lbs of fuel pressure is what mine runs at, without the regulator it will run but not as smooth as its supposed to and will flood a lot easier
 
1 - 8 of 8 Posts
Top