Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Has anyone experienced this kind of engine/EFI noise? Its like a rattling sound when I reach 3000rpm and above thats about 60kph and above, but when I ease up on the gas pedal noise disappears and when I step again on gas it rattles again. This only occurs at 3000 rpm and above even on idle. Does anybody know how to eliminate this sound? Is there something wrong with my engine or my EFI though it runs smoothly except for the rattling noise. Need help badly:( TIA
 

·
Registered
Joined
·
177 Posts
roblacer said:
Has anyone experienced this kind of engine/EFI noise? Its like a rattling sound when I reach 3000rpm and above thats about 60kph and above, but when I ease up on the gas pedal noise disappears and when I step again on gas it rattles again. This only occurs at 3000 rpm and above even on idle. Does anybody know how to eliminate this sound? Is there something wrong with my engine or my EFI though it runs smoothly except for the rattling noise. Need help badly:( TIA
Try checking for loose parts under chassis (just a guess).
By the way try reading the other thread which you also raised
this question. There were some replies there which you can find
useful.
 

·
Registered
Joined
·
18 Posts
I think you need the replacement of of MAP sensor fitted just on the air filter box you can see the two thin rubber hoses on it if your mini has automatic transmission. one hose coming on efi system and other going in air tank beside the air cleaner. check it out and let me know as I also need the same part.

regards,
 
1 - 3 of 3 Posts
Top