Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I've been looking all over for inspection procedure for the MAF, its the mechanical type with moving inner core acting as a potentiometer. Only stuff I can find so far is based on US models, my manual doesn't have any thing... its probably the wrong one! The one I have fitted is a Denso 13800- 57B00, it looks like the below:


Screen Shot 2021-03-31 at 6.08.54 pm.png


Its not throwing an error code but car running real rough at idle (if running at all), I can hear the MAF banging around when engine is turned over. I have removed and cleaned, still the same. I can hear a loose part inside when I shake it. Terminal D has 5 volts.

Any feedback appreciated


MAF.jpeg
 

·
Super Moderator
Joined
·
15,191 Posts
Rhinoman's Suzuki Service Manuals

Try the manuals at the link above...

99501-60A50 has the details, but - I doubt it's going to tell you anything you don't already know - something's loose inside.

I guess it's time to open it up and see how badly broken it is.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Rhinoman's Suzuki Service Manuals

Try the manuals at the link above...

99501-60A50 has the details, but - I doubt it's going to tell you anything you don't already know - something's loose inside.

I guess it's time to open it up and see how badly broken it is.
Great thanks, I must have missed this one, will check it out. Probably need a new MAF but want to fault find it first.
 
1 - 3 of 3 Posts
Top