Suzuki Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hi all, so the power window on the drivers side was gradually dying by struggling to move until finally one day it stopped altogether.
I then looked for a wreckers selling a second hand power window motor which was apparently tested and working.
Once I got it, I plugged it in and it doesn't actually work.
Now before I start blaming the window motor, I did some testing with a multimeter in the plug.
When I press down on the power window switch I get 12V and when I pull up I get -12V which confirms that the power window switch is sending a signal and that the right amount of power is getting to the plug.
Apart from that I the only thing left as far as I know would be the power window motor.
Before I demand a refund from the wreckers, does anyone have any other idea what the issue might be or in fact if there is some other test I can do with a multimeter on the power window motor itself?
 

·
Registered
Joined
·
7,191 Posts
Try cleaning the window guides and mechanism, these are known to get grime in them over the years and its like gluing the window into the tracks.
Confirm mechanical operation before blaming the motor or wiring
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
Try cleaning the window guides and mechanism, these are known to get grime in them over the years and its like gluing the window into the tracks.
Confirm mechanical operation before blaming the motor or wiring
Hey thanks for the suggestion mate, I should have mentioned I tested it before even putting it in the door so there is no mechanical interference at all.
 

·
Registered
Joined
·
7,191 Posts
I'm talking about the window glass and mechanism, not the motor itself. Can you wind the window up and down from the point where the motor connects into the window winding mech?

. I'm betting you have a perfectly fine motor, but a mechanical issue with the actual window. Clean the window tracks with soapy water, clean the pivots in the mechanism with brake cleaner then use a decent lubricant. I use a " dry" bike chain lube as it wicks into the pivots then drys leaving a good lube film that doesn't attract dust.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
I'm talking about the window glass and mechanism, not the motor itself. Can you wind the window up and down from the point where the motor connects into the window winding mech?

. I'm betting you have a perfectly fine motor, but a mechanical issue with the actual window. Clean the window tracks with soapy water, clean the pivots in the mechanism with brake cleaner then use a decent lubricant. I use a " dry" bike chain lube as it wicks into the pivots then drys leaving a good lube film that doesn't attract dust.
Yeah I've cleaned those things just as part of freshening all the necessary bits up, but the motor mechanism itself isn't even installed, I've just plugged it in and test it outside of the door so there is nothing that could mechanically prevent it from moving, see pic.

97397
 

·
Registered
Joined
·
7,191 Posts
You still havent told me if the window regulator actually moves freely or not. Try it with no glass and use a battery onto the motor to prove everything
 

·
Registered
Joined
·
17 Posts
Discussion Starter #7
You still havent told me if the window regulator actually moves freely or not. Try it with no glass and use a battery onto the motor to prove everything
What do you mean by 'try it with no glass'? Its not even in the door so obviously it has no glass on it.
I've already plugged it into the door plug, turned on the car and used the window switch, nothing happens.
I've also tested the door plug to confirm it is getting power and also confirmed the door switch is working.
What you see in the picture is the window motor with no glass, not installed and its plugged into the door plug.
The only thing left that could be the issue is the motor itself so is there some kind of test with a multimeter or anything else I can do to determine if the motor is ok or not?
I've tried manually forcing the mechanism to move but it doesn't, however I don't know if that is normal or not, it could be a motor that doesn't move unless power is applied but in this case, it doesn't respond to power.
 

·
Registered
Joined
·
7,191 Posts
Ok, if you have tried it directly off a battery and it doesn't move then the motor is faulty. Try this step first to prove the motor and mechanism.

Once you have proved or disproved the mechanism, multimeter on the plug that supplies the motor in the door, motor unplugged
Press door switch, should get 12 v on terminals at plug, press switch the other way, polarity should reverse

If that's fine, plug in motor and see if it moves. If it doesnt Then its possible the switch itself has corroded contacts allowing voltage to appear at plug, but no current.

You can't move the mechanism with the motor installed
 

·
Registered
99 Tracker, 5 door, 2L, 4x4
Joined
·
9,905 Posts
Just because you have open circuit voltage at the motor, that does not verify the circuit is good, bad/high resistance will flow voltage but fail to provide any amperage.. Always test circuits loaded...
 

·
Registered
Joined
·
17 Posts
Discussion Starter #10
Just because you have open circuit voltage at the motor, that does not verify the circuit is good, bad/high resistance will flow voltage but fail to provide any amperage.. Always test circuits loaded...
Yes good point there, so you know what my next question is going to be? ;)
So should I plug the window regulator back in, set the multimeter to Amps, find somewhere to put the probes on the wires, then use the window switch to see what kind of Amps are being drawn?
 

·
Registered
Joined
·
7,191 Posts
That's one way if doing it, but I'd prove it out of the car from a battery first to make sure it actually works and you're not chasing 2 different unrelated faults
 

·
Registered
Joined
·
17 Posts
Discussion Starter #12 (Edited)
That's one way if doing it, but I'd prove it out of the car from a battery first to make sure it actually works and you're not chasing 2 different unrelated faults
I see, what if I get some wires (around same gauge as the wiring for the window regulator plug), and run them from the car batter to the window regulator, won't that work?
Its 12V and the motor will draw whatever Amps it needs so if that doesn't work, then it will prove the regulator motor is a dud?
But then again, even if it doesn't work, it would be helpful to know what kind of Amps its supposed to be drawing.
 

·
Registered
99 Tracker, 5 door, 2L, 4x4
Joined
·
9,905 Posts
The issue right now is the window regulator is not functional, lets worry about the draw once the motor is validated,,
 

·
Registered
Joined
·
17 Posts
Discussion Starter #14
The issue right now is the window regulator is not functional, lets worry about the draw once the motor is validated,,
Ok so I hooked up the window regulator directly to the car battery and confirmed it actually works.

So to summarise, I used the multimeter and tested the door plug for the window regulator and confirmed it read 12V and -12V when I used the window switch.
I've also just tested and confirmed the regulator actually works off that car circuit so it looks like even though I get 12V, for some reason not enough Amps are flowing.

I haven't touched any of the cars wiring, could it still be simply bad wiring in the door? Could it still be an issue with the window switch even though I get a reading when using it?
 

·
Registered
99 Tracker, 5 door, 2L, 4x4
Joined
·
9,905 Posts
Now that you have confirmed the regulator works with a bi-pass, the evidence is in.

You have a high resistance circuit.. fix it..

Again, open circuit voltage readings are redundant as they prove nothing..!!
 

·
Registered
Joined
·
17 Posts
Discussion Starter #16
Now that you have confirmed the regulator works with a bi-pass, the evidence is in.

You have a high resistance circuit.. fix it..

Again, open circuit voltage readings are redundant as they prove nothing..!!
Ok I decided to check the window switch. I took it apart and had a look at the internal contacts and they were covered in what looks like carbon deposits.
Then I cleaned all of the contact parts and metal bits, put it all back together and it all works now!
So the high resistance was simply due to crud buildup on the metal contact surfaces in the window switch.
Five minutes and some isopropyl alcohol was all it took, imagine taking your car into a mechanics and getting charged for a new window switch.
Thanks again 'aquanaut20', you helped me 9 months ago with my alternator debacle and now you've come through again, should call you Obi-wan.
 

·
Registered
Joined
·
7,191 Posts
Dont forget some electrical grease in the switch, rapid wear and further arcing will result if you dont. Glad you found it and it was a simple fix.
 
1 - 17 of 17 Posts
Top