Suzuki Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Does anyone have any suggestion as to why my 1996 forenza (Chevy lacetti) hops why I press the accelerator. Could the clutch be going or is there some sort of plate that is slipping? I notice it around 55mph the most but anytime I accelerate quickly it happens. The clutch is original and has 116,000 miles on it.
 

·
Super Moderator
Joined
·
17,674 Posts
Define "hops". :huh:

Are your RPM's changing (advancing) when this happens?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I never had time to check, it happens so quickly. I have just had the timing belt replaced ( along with a head gasket), I wonder if it has something to do with it. I have also noticed that it almost stalls when I come to a complete stop.
 

·
Registered
Joined
·
3,098 Posts
sound like it could possibly be your iac sensor. it might need to be replaced. when it starts to go the car wants to stall at idle and can act up when driving.
 

·
Registered
Joined
·
3,098 Posts
well first of all what year is your car thats very important to know. i dont think its a 1996 haha!! the iac is the intake air temperature sensor.
 

·
Registered
Joined
·
3,098 Posts
haha im sorry its the Idle Air Control Valve. simply put it controls the cars idle. what can happen is the valve gets dirty and it stops working correctly causing a rough idle and frequent stalling. your cars an 06 so im guessing its a drive by wire model, electronically controlled throttle. unfortunately i dont know where its located on that system.
 
1 - 10 of 10 Posts
Top