Suzuki Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
The clutch cable on my 1999 sh410 993cc alto has started to exhibit signs of friction and makes a slight groaning noise on operating the pedal. The car has done 5000 miles from new so I would have expected it to last a bit longer - questions - is this common? Can it be repaired by lubrication etc? Where would I get a replacement? - there's only one on eBay and it is in Australia where the postage cost is over twice the item price. Thanks in advance.
 

·
Registered
Joined
·
7 Posts
5000 miles in 20 years? If correct then I would suggest first checking all the linkages etc for corrosion, cleaning and lubricating as necessary.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
Where is the go-to place for spares for my Alto in the UK - in case I need a clutch cable pls.
 

·
Registered
Joined
·
4,777 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #8
Thanks for the link - I now have a "blue print" cable - looking good at £24.
Update - replaced the cable with the pattern part - two bolts and 15 minutes work - then found that although the action was smooth the resistance was more and "felt" worse than the old one so I put the old one back on and now carry the new one and a wrench in the spare wheel compartment. Looking at the routing of the clutch cable with two sharp bends like that it looks to me as though this car was designed as left hand drive and the clutch cable on the RHD is a compromise/bodge as all drive cables should be as straight as possible - like it would be in a LHD.
 
1 - 8 of 8 Posts
Top