Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello I have an 2011 SX4. I just started having issues with the charging system.

First off no battery light comes on when I'm having problems but the ABS and ESP lights come on. Then the RPM and speedometer start acting weird then the radio starts flickering. Then the car dies. I have changed the battery but it does the same thing after a day of driving. My question is "Wouldn't the Battery light come on if the alternator was bad??"
 

·
Super Moderator
Joined
·
17,568 Posts
The battery light will not always come on with alternator (or other) electrical issues. If the alternator was completely shot then yes, but if the regulator portion is causing issues, no.

Have you a local Auto Parts Store that can evaluate your charging system for free there? :)

Welcome aboard too!
 

·
Registered
Joined
·
2 Posts
Alternator low voltage

Hello Newbie. Original owner 2011 Zuni SX4 crossover 85k miles , and yesterday all of a sudden the car balked at around 40 MPH and every light on the instrument panel came on.

Drove about 2 miles to my home turned engine off. And battery completely dead. Could not turn over engine.

Charged (original battery) overnight on smart charger and went to local auto store first thing in morning . They have a Medtronix MDX-650P NAR tester. And it tested everything with battery in car and diagnosed bad charging. Low out put

12.06 V no load and 11.98 V With Load ( bright lights, blower on high radio on).

So. I cleaned terminal posts well. And now on my DVM got 11.5 V, but as I let it run watched voltage drop to <10 V and all instrument lights came on and pretty much battery is dead.

Called dealer since I thought I had 100k mile warranty. Only to find that alternator is only 5 year or 60k miles.


Sooo needless to say frustrated, especially when I read how difficult access removal and replace is and intake leaks possible, etc...

I have Audi’s with >240k miles with original alternators. So is there any other test I can do to verify alternator/regulator is dead. No instrument light came on to indicate charging probllem ever.

And never have had a single problem with SX4 from first mile we bought it.

Thank you.
 

·
Registered
Joined
·
815 Posts
regulator is built-in , parat of alternator. In another car, I had a charging problem and the feed wire to the alternator (the one that gets HOT with KEY ON to "excite" the alternator) was cut somewhere by corrosion. THere are cases also where the fusible link on the heavy wire from alternator to battary is shot. BUt actual alternator failure with the SX4 has been reported in several threads that describe a few tricks to get around nuisances.

Try to find those threads. here are some

http://www.suzuki-forums.com/suzuki-sx4-forum/221497-2010-sx4-alternator-replacement.html
http://www.suzuki-forums.com/suzuki-sx4-forum/172361-alternator-removal.html
http://www.suzuki-forums.com/suzuki-sx4-forum/46412-sx$-alternator-removal.html

The shop manual several have (for 2007-2009 J20A engine) describe the removal for cars equipped with electric power steering. But ours have hydraulic P/S, hence a P/S pump....and a J20B engine
 
1 - 4 of 4 Posts
Top