Suzuki Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, I drive a 2008 Suzuki SXA base model and I once again have the check engine light code on for my Catalytic Convertor. I just had it replaced last November and it was covered under the Suzuki Warranty. I was wondering if anyone else has had issues with this and if sowhat they did to fix the issue. Could it be something more to it?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I had the diagnostics done this evening and it is indeed the catalytic converter. Guess I as just thrown off considering it was just replaced not even a year ago.
 

·
Registered
Joined
·
3 Posts
I went to the local dealer, he said Catalitic converter was bad.

So I first cleaned the catalytic converter with Dawn, put it back and it worked for about 1 week, then check engine light came on again.

I replaced the o2 sensors, (Walkers from rockauto) and light has now gone off and stayed off for the last 2 weeks.
So too soon to say if this fixed the problem.

I still have engine vibration problems, but I think I'm runing to light an oil for the high temps in Florida, so going to up the oil and see if this fixes the problem, and improves mileage.

Before that, going to de-carbon the engine with bg44k, so that I' starting with clean internals.
The vehicle has 120k miles on it.

Next, looks like I'll need to add an oil pressure guage to see whats going on as I hear oil pumps can be a weakness on the Sx4.

Any other ideas?
 

·
Registered
Joined
·
94 Posts
I also have an '08 SX4 and the CEL has been on and off (mostly on) for the past 4 years. The code indicates catalytic converter but there is/has been no change in performance or fuel economy. I have driven over 120,000 Kms with this issue.

If I am going on a long trip then I just reset the CEL so that I can use the cruise control. :)
 

·
Registered
Joined
·
8,724 Posts
Keep in mind, the B1S2 will mimic the B1S1 if the values are too low/high..

So best to run a check on the B1S1 and fuel trims before condemning the CAT.

... Philip
 

·
Registered
Joined
·
19 Posts
I also have an '08 SX4 and the CEL has been on and off (mostly on) for the past 4 years. The code indicates catalytic converter but there is/has been no change in performance or fuel economy. I have driven over 120,000 Kms with this issue.

If I am going on a long trip then I just reset the CEL so that I can use the cruise control. :)
Same thing Ive been seeing for last 40k miles.
 

·
Registered
Joined
·
35 Posts
Welcome to the Catalytic Converter Club. I had the same problems as well.
1. Bought California Emission Cat Converter 3rd party. Could not afford genuine Suzuki Cat.
2. Spent $360 on Suzuki genuine Cat upstream sensor

$360 Upstream Sensor (geniune suzuki)
$600 Cat
$200 labor

All worked fine for 3 weeks. Then Engine light came back on. Kept on getting sensor reading issues.
Now I needed a Cat Sensor Downstream sensor for $229. I gave up and just left it like that with engine light on dash board.

3 months later when summer kicked in, the engine light just vanished. Its now November, light never came back.

I'm thinking temperature conditions
 

·
Registered
Joined
·
8,724 Posts
I hate to flog a dead horse, but unless you check the O2 Voltage and the fuel trims the issue will not be resolved..

The CAT requires a balance of fuel and air in order for it to fire up, too rich a mix will be its demise...

... Philip
 
1 - 9 of 9 Posts
Top