Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1 (Edited)
Hey Guys, 2004 Foenza 5 speed. Get to work this morning everything is good go to leave work and I have normal amount of power but the car won't turn over, no click no nothing. Acting like I have dead battery but it's not dead at all. I get somebody to come over and boost me (knowing it's not the problem) but when I pump the clutch it tries to turn over in small increments then finally it starts. Now I have it home and the same thing but not turning over at all. Could this be a safety neutral switch?

Update: With clutch pedal completely depressed call will not start but if I let it in and out and very short and fast intervals I can get it to start as long as I don;t let the clutch go all the way in or out. Very strange and would love to hear some thoughts on this.

Thanks
 

·
Registered
Joined
·
149 Posts
Take a look on the clutch pedal shaft near the top. There should be a switch on it with two wires coming out of it; one yellow and one gray. This switch is going bad.
I can't give specifics about where the switch is exactly, as mine is an automatic and I can't find the switch in the manual anywhere but the wiring diagram (that's how I know it has a yellow and a gray wire).
***You can remove the switch and jumper the wires together, but you must be mindful that the car WILL start in gear even with the clutch out!***
This will allow you to use it in the meantime, but be sure to buy a new switch ASAP or try and disassemble the one you have and clean or repair it if so mechanically inclined.
 
1 - 3 of 3 Posts
Top