Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hey guys I have a Japanese alto 2009 model G2 variant 660cc (HA24S) it has K6A engine and 180K mileage , I am facing two problem one is acceleration issue like I have to press the pedal hard sometimes and also its consuming too much fuel , fuel that use to last 3 weeks easily isn't even lasting 2 days now until it goes into reserve , I don't even drive the car that much , things I've tried so far got its catalytic converter and throttle body cleaned , transmission fluid changed and spark plugs , air filter changed and engine oil changed but it made no difference


So far I've been suggested getting these things checked & cleaned '' fuel pump , fuel injectors , fuel filter , TPS sensor , O2 sensor and MAF sensor ''

Any more suggestions will be appreciated
 

·
Registered
Joined
·
4,731 Posts
get fuel pressure checked, MAF and Throttle body clean, new plugs. Get someone with a live data scanner to look at the fuel trims and see where its actually using the fuel. Scan for pending codes, check for vacuum leaks.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
As mentioned earlier in my post the throttle body was cleaned and the spark plugs changed but alright I've noted the extra things that you mentioned in my list
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
get fuel pressure checked, MAF and Throttle body clean, new plugs. Get someone with a live data scanner to look at the fuel trims and see where its actually using the fuel. Scan for pending codes, check for vacuum leaks.

It turned out that one of the engine coil was bad so I've replaced all three and now my car is like new :D
 
1 - 4 of 4 Posts
Top