Suzuki Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Brake light stay on.. press brake pedal, release pedal brake lights go off.... for about 10 seconds and then just pop back on! I replaced the brake pedal sensor but didn't solve the problem! Any idea what is causing this issue?
 

·
Registered
Joined
·
5,941 Posts
brake pedal sensor? do you mean the brake pedal light switch? and did you adjust it properly? pedal fully released, push switch in until it just bottoms then secure it? thats all there is in the brake light circuit unless theres a short, unplug the pedal switch, lights should stay off. If they do, you have something wrong with the switch adjustment.
 

·
Registered
Joined
·
5,941 Posts
Brake pedal light switch is what I replaced
ok, adjustment on those is very easy to get wrong. I suspect thats whats happening here.
 

·
Registered
Joined
·
5,941 Posts
oh shit, its "that" model.....good luck
the calibration of those sender units is like a TPS, got to be "just" right or they will do all sorts of stupid things, it uses a "light" press to cancel the cruise control and a "heavier" one to turn on the brake lights
 

·
Registered
Joined
·
5,941 Posts

·
Registered
Joined
·
1 Posts
Brake light stay on.. press brake pedal, release pedal brake lights go off.... for about 10 seconds and then just pop back on! I replaced the brake pedal sensor but didn't solve the problem! Any idea what is causing this issue?
Did you ever get ths issue resolved?? I have the exact same issue with my 08 XL7.
 
1 - 11 of 11 Posts
Top