Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi folks.

First post here, so hoping to get some great advice :)

Bought a 63 plate Alto with 3000 miles on the clock and in just 2 months, we've had 5 issues.

1. The spare wheel didn't have a bracket to hold it down. There's a threaded bolt but nothing to attach to the wheel itself. I'm going to report this to the garage shortly.

2. The jack isn't strapped down, so it rattles and bangs against the metal mount when you drive down the road. Can anyone explain (or provide a picture) of how the jack should be stored? I don't believe Suzuki just left it rattling around!

3. At cold start, there's a squeal as you rev the engine. It sounds like a belt, but the garage have already "dressed" the fan belt and it's done precisely nothing.

4. The driver's seat moves. As you go round corners, the back of the seat moves and clunks.

5. MPG. It's not half as good as I expected, but it's only 5 months old and only has 4k on the motor. Have you seen an increase beyond run-in? Bear in mind I've come from a 400BHP SAAB to a 3cyl 1.0, it's certainly better but I wouldn't call it especially economical either. I'm getting 40/42 around town, maybe 45 on the motorway. Is that normal?

Thanks!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
80 odd views and not even a "hello" ...

I've solved #2 - Turns out you have to expand the jack to fill the gap, there aren't any straps.

#4 is actually the seat, not the mountings. It's going to need a new one.
 

·
Super Moderator
Joined
·
13,770 Posts
Hello Paul.

About that advice - let's start with be patient - nobody's sitting around waiting to respond to you, and few of us have a clue as to what a "63 plate Alto" is, so you're going to get views from people who are curious, but not in a position to assist.

Just so you're aware of it - all "63 plate" says to most of us, is that you're probably in the UK, if a UK member read it, he might have an idea as to the age of the car (or rather when it was registered, because date of manufacture and date of registration can be completely unrelated.

Now - you have quite a list of complaints - which are actually best discussed with the dealer you bought the car from - I can't quite figure out, if you bought it new or used - if new, take it back to the dealer and him address the complaints, if used, what were you expecting?

You've figured the jack out for yourself, the spare wheel retainer is obviously missing, the driver's seat sounds like it's broken - belt dressing, in my opinion is a "no no" (quite obviously not everybody shares that opinion), if the belt is slipping it either needs tightening or replacement and the mpg - well - it's been many years since I sold my Alto, so it's probably not the same vehicle, but at 40+ mpg, I wouldn't be complaining - if I were to assume you've done 3~4000 miles in five months - I'd say you're running it pretty hard, and if that's correct, well, it will burn more fuel.
 

·
Registered
Joined
·
5 Posts
Hi there. I have a 63 myself, had a few issues that don't sound exactly like yours but I will chip in anyway. Sounds like the previous owner was not happy with a decent city car and needed something bigger! The car is new enough whereby you can get most major problems sorted under warranty. It won't have even had its first service

Did you get the warranty for the car transferred? I've got 5500 miles on mine and had two issues with it and the dealer sorted one out under warranty (will describe shortly.)

By the way, for the benefit of non-UK users reading this plate, a '63' plate is a car first registered - not built, but it's usually close and first use isn't until after registration - in late 2013, specifically any time after 1st September.

1. I have a bolt with a butterfly wing in the top lug hole of the space saver to keep the wheel down.

2. I don't remember a metal mount (I haven't been to get the jack in a while...) but you're storing it in the hidden cubby hole on the right of boot wall as you look in, right? As I recall, there's only one orientation you can really use to store it, and there's no strap or anything in there. It shouldn't rattle in there, if it does, adjust it.

3. I had a squeal that I was mis-identifying as a belt when idling after driving for a while, because the squealing disappeared as I applied throttle. Try this - does the squealing disappear when you apply any pressure on the clutch? I took the car back to the dealer to replace the clutch bearing, and this sorted it all out. If not then it's worth looking at the belt tension, but if you're not used to adjusting drive belts, this might be difficult for you to work out yourself.

4. How much do they move? The front seats are a little notchy when adjusting the back. If they're not in a proper notch then they'll not be totally secure, but they'll slide into place - doesn't sound like yours is locking properly. The adjustment handle for the back of the seat is plastic and I've found it's not really keen at returning into a locking position - try applying very gentle pressure to lock it back instead of relying on the spring? If not, try the dealer again.

5. You always have to take MPG rating with a pinch of salt, you're not likely to reach the 65MPG extra-urban rating in normal driving. However, I agree, with those figures I'd suspect something was up. To tell you the truth I am still working on it - MPG improvement happened from the loosening up of a new car at about 2500~ miles, so I don't think you'll see any more run-in improvement. I was averaging 45MPG last month, with my high-score of 49MPG if I was *really* trying to max out MPG with smooth and relaxed driving. I do about 50 miles a day and spend almost all of it at 60MPH. What I did was to get the wheel tracking checked at my local shop - they found it was off (wrong from the factory/dealer is actually rather common) and after adjustment, I noticed slightly better steering but now I see above 50MPG on average without effort, and I could probably get another five if I drive aggressively. I still reckon there's more to discover with this one, so I will get back to you if I discover anything that is potentially an issue with this particular batch of Altos. If I don't find anything before its first service, I'll see if the
HTML:
<s>stealership</s>
dealership will have a look without ripping me off. If it wasn't for the warranty I'm trying to keep fresh, I'd have already pulled the car apart.. I'm notorious for tinkering.


So far I think it's a great car despite the few hiccups I've had so far, miles better than the Peugeot 107 I was glad to replace (though it's not hard to improve on a Peugeot.)
 
1 - 4 of 4 Posts
Top