Suzuki Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
My 95 geo 4x4 manual transmissions keeps blowing the turn signal fuse when I put it in reverse .
 

·
Super Moderator
Joined
·
24,636 Posts
The turn signals and the back up lights work off the same fuse - so basically you are saying that when you put your car in reverse, the reverse light fuse blows. The circuit works off of the yellow wire, but is somewhat different, depending on what transmission you have....???? I would probably start at the wiring at the rear of the car and work forward, as the rear tail light area is known for rust. You have a short somewhere....
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
I have looked for the short all day can't seem to trace it down" I took the bulbs out of the backup light at least it don't blow the fuse now and my turn signals work just don't have reverse lights.
 

·
Super Moderator
Joined
·
14,229 Posts
Tried new reverse light bulbs yet? If removing the bulbs stop the fuse blowing, the problem is either the bulb or the socket.
 

·
Super Moderator
Joined
·
24,636 Posts
You can probably track it down even further by trying one bulb at a time, to see which side is giving you the problem.....
 

·
Super Moderator
Joined
·
14,229 Posts
Hi Zimo, did you find out what the issue was? I'm experiencing the same hurdle. Thanks
Did you read through the thread, have you followed the suggestions? Same symptom does not mean same problem - it does however require you to follow the same troubleshooting steps.
 

·
Super Moderator
Joined
·
24,636 Posts
Hi Zimo, did you find out what the issue was? I'm experiencing the same hurdle. Thanks
Welcome to the forum. You really need to start your own post, rather than piggybacking on these old ones. Identify what you’re driving, your location, etc., and put that into your signature.
What exactly are your symptoms? This thread is about the turn signal fuse blowing when the reverse lights are on. The other post you responded to just indicated the fuse blew without any other conditions. So, your fuse blows, whether left or right signal? Do your hazard lights work? Give the specific details, in your own post, so that we can help you.
 

·
Registered
Joined
·
6 Posts
Welcome to the forum. You really need to start your own post, rather than piggybacking on these old ones. Identify what you’re driving, your location, etc., and put that into your signature.
What exactly are your symptoms? This thread is about the turn signal fuse blowing when the reverse lights are on. The other post you responded to just indicated the fuse blew without any other conditions. So, your fuse blows, whether left or right signal? Do your hazard lights work? Give the specific details, in your own post, so that we can help you.
Thanks @Bex and @fordem. I apologise for jumping into the thread without providing enough info. I was hoping that @Zimo had found the problem and I could try his fix. Anyways, I'll go through the suggestions provided and post the solution (if I find it).
 

·
Super Moderator
Joined
·
24,636 Posts
Again, we can try to help, if you identify exactly what you are driving and what the specific symptoms are.
Questions to be answered:
Are turn signal relays ticking?
Does the fuse blow at key on, or when the engine is running?
Is It both left and right turn signals?
Do your backup lights work (both are on the same fuse)
Do your hazards blow the fuse?
Etc.
While symptoms may appear the same, often the reasons for them are not.
 

·
Registered
Joined
·
6 Posts
Again, we can try to help, if you identify exactly what you are driving and what the specific symptoms are.
Questions to be answered:
Are turn signal relays ticking?
Does the fuse blow at key on, or when the engine is running?
Is It both left and right turn signals?
Do your backup lights work (both are on the same fuse)
Do your hazards blow the fuse?
Etc.
While symptoms may appear the same, often the reasons for them are not.
Hi!
I did not have the time to start searching for the short but here are answers to some of questions:

Are turn signal relays ticking?
No

Does the fuse blow at key on, or when the engine is running?
Hard to say. The turn signal will work fine for - let's say - one morning, but eventually they will stop working after that. Not really sure the exact moment/action as my partner is the one using the vehicle.

Is It both left and right turn signals?
Yes, both.

Do your backup lights work (both are on the same fuse)
No, it does not work.

Do your hazards blow the fuse?
No. Both turn signals work fine on hazards mode.

I'm a proud owner of a Suzuki Grand Vitara 2.0 TDi II (year 2002) ;-)

I'll post any relevant updates.
Thanks!
 
1 - 12 of 12 Posts
Top