Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all,

I was hoping to get some help with an issue for my Suzuki Jimny 08 JB43V, I have recently replace the fuel filter, and it seems to still have issues with (what I think) is fuel. I have just taken the tank off again, checked all the fuel lines, tank, fuel quality, but am convinced there is still an issue but perhaps not fuel! Where do I start to eliminate causes??? The problem it causes is kind of like hiccups, or heart murmers, it seems to skip a beat!!! it got a lot worse before I changed the filter, almost loss of power, and no grunt anymore!! Can anyone please help me assess the issue, and hopefully finally get to the bottom of the issue!!

Regards,
Nicky
 

·
Registered
Joined
·
1 Posts
Injectors

Hi there, I have been having fuel problems with my little suzuki also. Have you tried changing your spark plugs? I am about to drop my fuel tank and put a new filter and pump. I also would like to get my injectors done. think i might have to pull them out and bring them to AFI for a bubble jet clean cause suzuki want $310 for each injector new! I have the G13BB engine.
 

·
Registered
Joined
·
5,299 Posts
If the problem is cutting out when hot then it is usually a cam or crank sensor problem.
 

·
Registered
Joined
·
4 Posts
shudder!!

i have the same problem when my suzuki sierra 1.3l warms up. its a 1995 and 3rd, 4th and 5th all chudder and loose grunt until i hit about 90km p/h it sits at 3 thousand rpm comfortably. not sure if you have the same problem but my odometer jumps during these gears from 2 thou - 8 thou continuously?? :huh:

ive been told to clean fuel lines, do a carby tune, reset timing etc.. $$$

ive replaced the fuel filter, air filter, done all new gaskits everwhere and reset tappets.

my air intake butterfly flap before the actual air box doesn't work and im missing the occasional hose here and there over the whole engine, the coal box? isn't attached to anything and my hot air hose is gone?? :huh:

really confused as i do not think my engine has cam sensors?? ind im not in any position to spend $$$

pls if anyone can give me the cheapest way to fix these problems it would be greatly appreciated :)
 
1 - 4 of 4 Posts
Top