Suzuki Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
hi

my lights dim and brighten according to throttle use. is this due to the altenater?
also if i have my lights on and wipers running my radio will flick on and off. anyone know a possible reason for this, i've checked fro loose cables/connections.


thanks in advance
 

·
Super Moderator
Joined
·
12,450 Posts
I'm more inclined to think the battery may be on it's last legs - how about you tell us where you are and what you're driving?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
I'm more inclined to think the battery may be on it's last legs - how about you tell us where you are and what you're driving?
sorry, driving a 1992 suzuki sj413. it has a 1.6 8 valve suzuki vitara engine fitted. i live in cork, ireland.
i don't think the battery is the problem, it always starts first time, even after sitting idle for months, seems to have plenty power in it.
I've heard the altenater isn't great in sj's. is it worth the money to swop it out?
 

·
Super Moderator
Joined
·
12,450 Posts
Get a voltmeter, set it to the 20V DC range and connect it across the battery terminals - make a note of the voltage, it should be somewhere between 11~13 volts depending on the batteries state of charge, now start the engine and check the voltage again, with the engine at idle, make a note of the voltage again, it should be slightly higher than the first reading - between 1~2 volts higher, now turn the lights on - what happens to the voltage?
 

·
Registered
Joined
·
53 Posts
I'd say the regulator in the alty,

Regulators are supposed to change 3 phase AC power into DC 12.
Often, you'll blow out a set of diodes that rectify 1 of the 3 phases giving you a dip in voltage every time the stator passes that dead point.

Change the alty.
 
1 - 7 of 7 Posts
Top