Suzuki Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Had this indicator come on and it was checked with an analyser.

Lean fuel mixture was the code so upper cylinder lubricant was added
and the warning cancelled.

I was advised that as it is a used Japanese vehicle I should use 95 octane
and not 91 unleaded so I topped up the fairly full tank with some 95.

The light came back on this afternoon!!

I was also told it might be a filter that needs replacing??

Any leads on this guys please

mikewest
 

·
Super Moderator
Joined
·
15,039 Posts
There was a numeric code - what was it?
 

·
Super Moderator
Joined
·
15,039 Posts
OK - now that you have the code, troubleshoot the problem.

Adding upper cylinder lubricant will NOT correct a lean mixture problem, changing the fuel grade will NOT correct a lean mixture problem - you need to find out WHY the mixture is lean and fix THAT.

Take a look at this page for some possible causes.

OBD-II DTC: P0171 System Too Lean (Bank 1)

If you lack the skills to do this yourself, find a competent mechanic (someone other than Mr Upper Cylinder Lubricant).
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
Engine Light and P071

After establishing that it's probably the MAF I found that the 2 screws
securing it have strange head with a 5 pointed star indent unlike Torx screws
with a six point shape.

Has anybody faced this problem as cleaning the MAP is straightforward but only if I can remove it.

Meanwhile will replace the PCV valve with a new one.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
Still trying to sort out a CEL indication

Car is running well with good performance and accelleration

Engine idling speed in gear has suddenly changed from 750 to 1000

Am advised that my M18A engine does not have a MAF sensor

Could my problem be the MAP or O2 sensors I wonder???
 
1 - 7 of 7 Posts
Top