Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2011 SX4 that I love. I've had issues with the AC for about 6 months. Sometimes it works, sometimes it doesn't. The dealer is now a KIA dealer and they claim the compressor needs replacing.

There is also a noise that has started more recently which I hear when I go above 40mph and then it winds down when you drop the speed. I assumed this was a separate issue but the dealer says it's the same thing.

So my questions for anyone out there are:

1. Is this really the compressor even though it works fine some of the time? I thought maybe just the AC clutch?

2. Is there a noise that can sometimes occur with a problem like this? It does sound like it might be closer to the cabin and does not happen at anything lower than 40mph.

The car is running perfect otherwise and since I can't get a new one, I want this one to last as long as possible!

Any input would be appreciated!
Rob
 

·
Registered
Joined
·
1 Posts
S-Cross Air Con Problems

I have an 18 month old S-Cross.
I have had the annoying problems mentioned elsewhere with the satnav and rear sensors and it being prone to stone chip damage - but after a recent service found my aircon not working.
Had it back into the dealer (twice) as they had to get a specialist team in - apparently the S-Cross uses the new gas that can't be re-filled by most dealerships - only to be told the compressor is 'damaged' and so not covered under warranty.
The compressor I'm told is situated low down at the front (a vulnerable place to site it I thought for a 4x4 car) but at looking at it I fail to see how it could be damaged other than by grounding the car (which I haven't)
I'm taking a 2nd opinion but would be interested to hear if anyone else has had similar problems?
 

·
Registered
Joined
·
8,438 Posts
Unfortunately, without testing and diagnosing, you are just guessing...

A MM and stethoscope would be first line...

.. Philip
 

·
Registered
Joined
·
826 Posts
... after a recent service found my aircon not working....
Is that directly consequential to the "service".....in which case it is rather a disservice. IF they played in the vincinity of the A/C compressor or sensors, changing oil filter...etc....they may have unplugged something...
 
1 - 4 of 4 Posts
Top