Suzuki Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Hey Guys,

I am new to the forum. I have a 1988 Samurai. I am having some issues with my AC. For some reason I am not getting any power going to compressor or electric fan. Does anyone have any suggestions on what I need to check for?
Your help is most appreciated.
 

·
Registered
Joined
·
20 Posts
sounds like your ac system is low on gas. they have a pressure switch that will not let ac work if the pressure is to low.can be checked at a garage that re-gasses ac systems. hope this helps.....
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
Thanks for you help dmce!!

That's what i was told so i charged the system with 134 freon, but i am not getting no eletric power to the compresser or fan!
 

·
Registered
Joined
·
327 Posts
Is this AC system converted to 134a? And how did you charge it the compressor doesn't run?
If the system isn't converted you just screwed up, 134a will mess up the dryer sooner or later in an R12 system and will gum up in the presence of mineral oil..

If it has a pressure cycling switch you'll need to jumper the wires until the charge is sufficient to run the compressor, if not then you have an electrical problem you need to fix first.
 

·
Super Moderator
Joined
·
17,600 Posts
I think that you may be overlooking a simple blown fuse or wiring / relay problem here. ;)

I'm not versed well enough in your model to point you to the fuse (fuses ?) or wiring specifics, but you need to check wiring from the A/C switch to the fan and compressor IF not a fuse problem. Having neither the fan nor the compressor working indicates an open 12V power source.

Once you re-establish the circuit's power, further troubleshooting may be needed to find out why the fuse popped to begin with.

Also, I'm with Isuzuzuki man. You can't charge an A/C system without a running compressor. IF you were able to squeeze in some freon, then the system was bone dry or super low to begin with, indicating a very large leak. :(
 

·
Registered
Joined
·
34 Posts
Discussion Starter #6
Thanks guys for your help!, Since i bought this sammy the AC has not worked and it's gotten so hot here in Arlington texas and i would not mind a litlle cold one in a while, i was told that the system just need to be charged but i wanted to make sure the compressor was working, so since i was not getting any power to the compressor so i got made a jumper wire from the compressor to the battery and the compressor starting work and this is how i recharged the system and the air got cool but not cold but i am guessing due to the fan not coming on because the is no power going to the the compressor or fan! Does any one have a or know a website i can go to to get a break of the Ac system, i would realy like to have a good shop repair manuel. And agian thanks for you help guys!
 
1 - 6 of 6 Posts
Top