Suzuki Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I have a 97 Geo tracker. I had to replace the under dashboard and most of the motor wireing harness. Since then the AC doesn’t work. It did before the swap. I apparently missed a plug along the line somewhere. The indicator light on the dashboard switch doesn’t light up. Tested the switch and it’s good. There is no voltage to the plug. I checked the plug on the harness at the engine compartment. green and yellow wire feeding from the firewall have 12 v on them. When I unplug and plug the plug up the cooling fan will momentarily come on. This is with the ignition on and engine not running. Could that plug be bad?what would be common that I can run power to the system. I’ll want to rig a switch to power the system. Any suggestions to get it running would be great. I’m not pulling the dashboard.
 

Attachments

·
Registered
Joined
·
8,814 Posts
You only salvation is to use the schematics and if you have to yank the dash,
it is what it is!!!

It is not likely to fix itself..

... Philip
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
I don’t have a schematic for the electrical system. That would be great help.
 

·
Registered
Joined
·
4,310 Posts
Hopefully Bex will see this & give you a link to Ack's website, or, PM me and I can send you pdf files of the FSM, if my scanner (it's angry at me) is working, lol.
 

·
Super Moderator
Joined
·
12,434 Posts
Google Acks FAQ and type the words wiring diagram into the search box.

By the way - unplugging stuff under the dash with the ignition on is a very easy way to crate major headaches for yourself, you can take the ECU out like that.

The reason the condenser fan (it's not the cooling fan, that is engine driven) starts & stops when you play with the plug is the a/c amplifier is momentarily sensing an engine overheat condition, and starting the fan to help cool the engine.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
thanks for the information. Wondered why that was happening. At least I know it runs.
 

·
Super Moderator
Joined
·
23,887 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #9
Yeah I went there before but couldn’t get it to open correctly. But I was trying on a mobile device. I’ll try a laptop this time.
 
1 - 9 of 9 Posts
Top