Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1 (Edited)
Alright guys, I've hooked up probably 10 aftermarket stereo systems in all different types of cars but when it comes to hooking one up in my 99 Vitara, i've hit a wall...a firewall ;)
where on the firewall can i feed my 4 gauge amp power wire through? I looked and looked but am having trouble finding an exact spot...

im pretty sure im gonna end up buying a compacitor too...as my lights dim out when i hold 2 of the power window buttons down at the same time...is that common or is something not right with my Vit?

-Chad
 

·
Super Moderator
Joined
·
18,017 Posts
The power drop is normal, as I see the same slight dimming that you speak of.

You may want to test the system out (after the whole stereo set-up is installed) to see if you need the capacitor. ;)

Wire routing pics in the A.M! :)
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
Niiiiiiiiiiiiice, thanks for the fast reply Max...you are the man!

thanks in advance for the pics of the wiring

-Chad
 

·
Super Moderator
Joined
·
18,017 Posts
There is an existing grommet with factory wiring passing through it just below and to the RIGHT of the battery (see the white and yellow wires). Just poke a dull round tool (a phillips screwdriver will work) next to the factory wires to open up the grommet a little, and pass your new wire through it....




It will exit behind the glove box, high in the passenger side foot area...


Now you can continue them over to the dash or stuff them under the carpet going back to your amp via the transmission tunnel or door sill areas.
 
1 - 4 of 4 Posts
Top