Suzuki Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hello everyone I'm new to this so excuse me if there is already a thread with my topic. I have a 1998 Suzuki Carry dd51t with the F6A, rear diff lock, and 4wd, it has 100k miles on it. It has been well taken care of oil changed and everything seems to be in working order with the exception of the AC. When you turn the fan on and push the AC the engine will idle up but the compressor does not kick in nor does the air blow cold. I checked the freon on the low side only and it showed to be over filled. ( I used the little cam with the gauge on it) so I'm thinking it's something with the compressor? Is there anything electrical that it could be on these trucks? The fan blows fine, but when I turned it over to heat to check the heater it doesn't seem to be blowing hot either. Any suggestions?
Thanks
 

·
Registered
Joined
·
553 Posts
First off, where are you? If in Philippines, they do not hook up the heater. for the AC, I would go to an auto AC shop, and let them have a look. There are so many things that will stop AC from working, but no heat seams to indicate it is not "plumbed", They left the hoses off the unit when rebuilding it.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
I am located in Oklahoma United States. The heater is working ok by my mistake just on feet and defrost which is fine. Is there something electrical that could keep the ac clutch from engaging that I could check before I take it to the shop?
 

·
Registered
Joined
·
8,412 Posts
What is the low pressure side reading?? Close to ambient air temp??

Check the wire at the compressor for 12vdc, if non check fuse and relay.

If yes, check comp clutch air space and ground..

... Philip
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
I checked today I'm not sure exactly what the low pressure side was reading the gauge just showed high or in red. I don't appear to have power going to the compressor. I am totally new to this type of vehicle though, would anyone happen to have or know where a service manual is or a wiring diagram? It would be greatly appreciated.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
I'm honestly not even sure where the fuse and relay is at on these things, I am in the process or looking it over to find everything.
 

·
Registered
Joined
·
553 Posts
Is this a right hand drive truck? If so, fuse box is on firewall under dash right side. PM me your email and I will send diagrams.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
Ok everyone, update, the clutch on the compressor appears to be working, I jumped the compressor over to the 12v and the clutch engaged, however aside from the wiring issue the air is blowing cool but not cold with the compressor engaged, I checked low side again for freon and it was at about 65 psi which still shows high on the gauge, any ideas?
 

·
Registered
Joined
·
8,412 Posts
I checked low side again for freon and it was at about 65 psi which still shows high on the gauge, any ideas?
The information you provide is useless,

65psi! is that static pressure? and what is the ambient air temp?

If you are seeing 65psi while running the A/C, you are over charged...

NOTE: you cannot properly diagnose an A/C system without an A/C manifold set..

... Philip
 
1 - 11 of 11 Posts
Top