Suzuki Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Good day folks- replies much appreciated-

As I said above- I have a 97 geo tracker (2 dr, 4wd) that is showing problems with the speedometer. I have read about this problem in other posts and I would like to do what is needed to fix it. It makes a rubbing noise when cold and a few days ago, on the hiway it showed that I was doing 95 mph (I was doing no more than 55). It also shakes at times especially at lower speeds. I wonder if the cable needs lube or has came loose?
Anyways, I see the two screws under the dash and the 2 places where it snaps on the front but I still cannot get the clear piece of plastic off so I can see to remove the speedometer to see what is going on. It feels like it is catching in the middle but I cannot see any screws to remove. Of course I do not want to break it. Any tricks to getting this puppy out so I can see if the cable is loose?

Thanks again and have a delightful day!
 

·
Registered
Joined
·
1 Posts
Help

I need to know how to do this! My speedometer gets stuck (as well as bounces in the morning from starting, low speed), and I want to avoid having to pay for a cluster repair if it's as simple as greasing the speedometer cable.

The reason I need to know is because I'm driving my 1998 Chevrolet Tracker across country from GA to CA in two days, and that's a lot of mileage covered by highway patrol! :p

Someone please explain in detail as soon as possible
 
1 - 2 of 2 Posts
Top