Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a automatic 95 tracker,I've had the AC worked on,new hoses made,new evaporator,condenser..everything. It still will not hold a charge for more than a day. Even with dye put in we cannot find a leak....tried everything! Can someone offer advice on what could be going on?
 

·
Super Moderator
Joined
·
17,655 Posts
You need the services of a A/C Technician with an electronic leak detector. Good chance that the leak is in the evaporator or condenser, and not easy to spot.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
My mechanic is going to try to call someone next week,he is completely frustrated. Its very hard to find anyone who knows about trackers around here so thought I would reach out on here,thanks!
 

·
Registered
Joined
·
4,751 Posts
You need the services of a A/C Technician with an electronic leak detector. Good chance that the leak is in the evaporator or condenser, and not easy to spot.
x2
Condenser and evap changed you said?

I am assuming you are using a decent black light and not just trying to eyeball the dye? If you are using Mk 1 eyeball, get a decent blacklight.

I'm betting you have a pin hole in a solid line somewhere, and it will be behind a bit of foam insulation, they always are!!! Checked the schrader valves? checked the pressure switch? (they leak around the body insert where its crimped onto the threaded section)

check the main compressor shaft seal too, thats a common source of leaks that people miss as the dye stains behind the pulley and can't be easily seen unless you get up close and personal with the black light.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thank you! I will mention these things to him. I'm pretty sure he's checked some of these already but I will tell him.
 
1 - 5 of 5 Posts
Top